parolmm
?>

Кнаписать программу на паскаль авс. вычислить значение функции z=cos (x) + y, где x и y изменяется от 1 до n.

Информатика

Ответы

agusarevich283

var

z: real;

x,y,N: integer;

begin

Write('N= ');

Readln(N);

for x := 1 to N do

for y := 1 to N do

begin

z := cos(x)+y;

Println('x=', x, '; y=', y, '; z=', z);

end;

end.

razumeiko0790

Паскаль. Вычисляет НОД для любого кол-ва чисел

Объяснение:

function Nod(a,b:integer):integer;{определение НОД двух чисел}

begin

while a<>b do

if a>b then a:=a-b else b:=b-a;

Nod:=a;

end;

var

   a: array of integer;

   n, i: integer;

   k: integer;

begin

 WriteLn('*** Определение НОД нескольких чисел ***');

 Write('Введите кол-во чисел N = '); ReadLn(n);

 SetLength(a, n + 1);

 WriteLn('Введите числа: ');

 for i := 1 to n do

  begin

   Write(i,'-e число: '); ReadLn(a[i]);

  end;

 WriteLn;

 k := Nod(a[1], a[2]);

 for i := 3 to n do k := nod(k, a[i]);

 WriteLn('Общий НОД всех чисел = ', k);

end.

marat7

1. Чтобы решить задачу, надо определить, какое количество варенья съест Машенька за 20 дней. Вначале вычислим это количество в ложках, если известно, что за день она съедает по 5 ложек варенья:

5 * 20 = 100 ложек.

2. Теперь переведем 100 ложек варенья в граммы, если известно, что каждая ложка помещает 5 г варенья:

100 * 5 = 500 грамм.

3. Если исходное количество варенья составляет 650 грамм, тогда вычтем из этой массы ту часть, что съест Машенька за 20 дней и получим массу оставшегося варенья через 20 дней:

650 - 500 = 150 грамм.

ответ: получили, что через 20 дней в банке останется всего 150 грамм варенья.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кнаписать программу на паскаль авс. вычислить значение функции z=cos (x) + y, где x и y изменяется от 1 до n.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Natysya7777
Burov1446
Aleksei806
serg1976g
annakuzina2023
Никита_Тузов
melissa-80
waspmoto6188
Anastasiya Yevseeva948
ВладимировнаАлександр1421
baxirchik
Vlad Petr531
layna1241383
Popova-Erikhovich
lyukiss