sahabiev1987
?>

Язык программирования python. работа со строками, списками и словарями1. есть список a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89]. выведите всеэлементы, которые меньше 5.2. даны списки: a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89]; b = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13].нужно вернуть список, который состоит из элементов, общих для этихдвух списков.3. напишите программу для слияния нескольких словарей в один.dict_a = {1: 10, 2: 20}dict_b = {3: 30, 4: 40}dict_c = {5: 50, 6: 60}4. вы принимаете от пользователя последовательность чисел, разделённых запятой. составьте список и кортеж с этими числами.5. выведите первый и последний элемент списка.6. напишите программу, которая принимает в качестве аргумента имяфайла и выводит его расширение. если расширение у файла определитьневозможно, верните строку «unknown file type».7. при заданном целом числе n посчитайте n + nn + nnn.8. напишите программу, которая принимает два списка и выводит всеэлементы первого, которых нет во втором.9. сложите цифры целого числа.10. посчитайте, сколько раз символ встречается в строке.

Информатика

Ответы

guujuu

#1

a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89].

for i in a:

   if a < 5:

       print(a)

#2

def f(a, b):  #функция для сливания двух списков

   ab = a + b

   ab.sort()

   return list(dict.fromkeys(ab))

#3

dict_a = {1:10, 2:20}

dict_b = {3:30, 4:40}

dict_c = {5:50, 6:60}

def update(a, b, c):

   a.update(b)

   a.update(c)

update(dict_a, dict_b, dict_c)

#4

array = list(map(int, input().split(",")))

cortex = tuple(array)

#5

array = [] #здесь твой данный список

print(array[0], array[len(array) - 1])

#6

def f(filename):

   try:

       return filename[filename.index(".") + 1:]

   except:

       return "Unknown file type"

#7

n = int(input())

print(n + n ** 2 + n ** 3)

#8

x = list(input())

f = list(input())

print(sorted(set(f) - set(x)))

#9

num = int(input())

print(sum(list(map(int, str(num

#10

string = str(input())

print(string.count('a'))

meu72

1)

var

  a: 100..999;

  a1, a2, a3: 0..9;   //а1 - сотни, а2 - десятки, а3 - единицы

 

begin

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a1, a3, a2);

end.

2)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin

   

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a2, a1, a3);

end.

3)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin 

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a3, a1, a2, a3);

end.

4)

var

  a: 1000..9999;

  a1, a2, a3, a4: 0..9;

 

begin

  writeln('введите натуральное четырехзначное число');

  readln(a);

  a1: = a div 1000;   //тысячи

  a2: = (a mod 1000) div 100;   //сотни

  a3: = (a mod 100) div 10;   //десятки

  a4: = a mod 10;   //единицы

  writeln('полученное число:   ', a4, a3, a2, a1);

end.

все остальное делается наподобие этого: просто в writeln меняешь местами цифры и все.

   

jamaltreid

var

  a: array[1..1000] of real;

  i, k, n, z: integer;

begin

  writeln('введите число n: ');

  readln(n);

  writeln('введите число z: ');

  readln(z);

  writeln('введите ',n,' действительных чисел (каждое с новой строки): ');

  for i : = 1 to n do

  begin

    readln(a[i]);

    if a[i] > z then

    begin

      a[i] : = z;

      k : = k + 1;

    end;

  end;

  writeln('количество замен: ', k);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык программирования python. работа со строками, списками и словарями1. есть список a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89]. выведите всеэлементы, которые меньше 5.2. даны списки: a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89]; b = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13].нужно вернуть список, который состоит из элементов, общих для этихдвух списков.3. напишите программу для слияния нескольких словарей в один.dict_a = {1: 10, 2: 20}dict_b = {3: 30, 4: 40}dict_c = {5: 50, 6: 60}4. вы принимаете от пользователя последовательность чисел, разделённых запятой. составьте список и кортеж с этими числами.5. выведите первый и последний элемент списка.6. напишите программу, которая принимает в качестве аргумента имяфайла и выводит его расширение. если расширение у файла определитьневозможно, верните строку «unknown file type».7. при заданном целом числе n посчитайте n + nn + nnn.8. напишите программу, которая принимает два списка и выводит всеэлементы первого, которых нет во втором.9. сложите цифры целого числа.10. посчитайте, сколько раз символ встречается в строке.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aleksagrbec39
Tatianamir765654
chizhenkovd9
dp199088206
ortopediya
alenaya69918
vasavto1
maxkuskov2485
olesyashazk5055
mayskiyandrey90
rsd737
Smirnovav1982422
bespalovaannaanna
kush-2640
Pavel1545