ams-sim
?>

Составить программу и определить, принадлежит ли точка с координатами (х, у) кругу с r=1 и центром в начале координат о(0, 0 уравнение окружности х2 + у2 = r2 if х * х + у * у < = r * r then writeln (‘точка принадлежит кругу’) else writeln (‘точка не принадлежит кругу’);

Информатика

Ответы

lokos201272

=B8+$B25

Объяснение:

Столбцы в табличном процессоре размечены английский алфавитом: A B C D и так далее.

В ячейку С5 (столбец С, строка 5) вводят формулу "=А6+$В23", после чего копируют эту формулу в ячейку D7 (столбец D, строка 5) ⇒ эта ячейка находится справа на одно значение и на 2 строки вниз от ячейки C5 ⇒ В введенной формуле изменится значение первого аргумента "A6"  на "B8", второй аргумент находится в частичной заморозке (ячейка B заморожена - не изменяется при копировании, а строка ячейки - нет) ⇒ "B23" заменится на "B25"

Rakitin
Uses crt;
type oc=record
       per,bt,tr:integer;
end;
ab=record
fam,im:string;
ocen:oc;
end;
var b:array [1..50] of ab;
l:ab;
i,n,g,k,h:integer;
begin
clrscr;
writeln ('введи количество абитуриентов');
readln (n);
Writeln ('Вводи фамилии, имена и 3 оценки');
for i:=1 to n do
with b[i] do
begin
readln (fam);
readln (im);
readln (ocen.per,ocen.bt,ocen.tr);
end;
clrscr;
for j:=1 to n do
for i:=1 to n-1 do
if b[i].fam>b[i+1].fam then
begin
l:=b[i];
b[i]:=b[i+1];
b[i+1]:=l;
end;
writeln ('Список всех аббитуриентов:');
for i:=1 to n do
writeln (b[i].fam,' ',b[i].im,' ',b[i].ocen.per,' ',b[i].ocen.bt,' ',b[i].ocen.tr);
writeln ('Список допущенных аббитуриентов');
for i:=1 to n do
with b[i] do
begin
with ocen do
if (per>30) and (bt>30) and (tr>30) and (per+bt+tr>140) then writeln (fam,' ',im,' ',ocen.per,' ',ocen.bt,' ',ocen.tr);
end;
readln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу и определить, принадлежит ли точка с координатами (х, у) кругу с r=1 и центром в начале координат о(0, 0 уравнение окружности х2 + у2 = r2 if х * х + у * у < = r * r then writeln (‘точка принадлежит кругу’) else writeln (‘точка не принадлежит кругу’);
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olenkalebedeva4477
horizma609
morsh9345
Екатерина1979
С(x∨¬y⇒x∧z)⇒¬(x⇒¬y)∨(y↔¬z)
and-syr
steger
horina12
bike-garage8
boykoz9
annakuznetsova841
николаевич-Елена988
игнатова_Сергей1228
leobashkurov1089
Михайлов
natanikulina1735
▲