байт (byte) — единица хранения и обработки цифровой информации. чаще всего байт считается равным восьми битам, в этом случае он может принимать одно из 256 (2′8) различных значений. для того, чтобы подчеркнуть, что имеется в виду восьмибитный байт, в описании сетевых протоколов используется термин «октет» (лат. octet).
килобайт (кб, кбайт, кб) м., скл. — единица измерения количества информации, равная в зависимости от контекста 1000 или 1024 (2′10) стандартным (8-битным) байтам. применяется для указания объёма памяти в различных электронных устройствах. 1 килобайт (кб) = 8 килобит (кб)
мегабайт (мбайт, м, мб) м., скл. — единица измерения количества информации, равная, в зависимости от контекста, 1 000 000 (10′6) или 1 048 576 (2′20) стандартным (8-битным) байтам.
гигабайт (гбайт, г, гб) — кратная единица измерения количества информации, равная 2′30 стандартным (8-битным) байтам или 1024 мегабайтам. применяется для указания объёма памяти в различных электронных устройствах.
терабайт (тбайт, тб) м., скл. — единица измерения количества информации, равная 1 099 511 627 776 (2′40) стандартным (8-битным) байтам или 1024 гигабайтам. применяется для указания объёма памяти в различных электронных устройствах.
петабайт (пбайт, пб) м., скл. — единица измерения количества информации, равная 25′0 стандартным (8-битным) байтам или 1024 терабайтам. применяется для указания объёма памяти в различных электронных устройствах.
эксабайт (эбайт, э, эб) — единица измерения количества информации, равная 26′0 стандартным (8-битным) байтам или 1024 петабайтам. применяется для указания объёма памяти в различных электронных устройствах.
зеттабайт (збайт, з, зб) — единица измерения количества информации, равная 27′0 стандартным (8-битным) байтам или 1024 эксабайтам. применяется для указания объёма памяти в различных электронных устройствах.
йоттабайт (йбайт, й, йб) — единица измерения количества информации, равная 1024 стандартным (8-битным) байтам или 1000 зеттабайтам. применяется для указания объёма памяти в различных электронных устройствах.
1 йoттабайт можно представить как:
103 = 1 000 зеттабайтов106 = 1 000 000 эксабайтов109 = 1 000 000 000 петабайтов1012 = 1 000 000 000 000 терабайтов1015 = 1 000 000 000 000 000 гигабайтов1018 = 1 000 000 000 000 000 000 мегабайтов1021 = 1 000 000 000 000 000 000 000 килобайтов1024 = 1 000 000 000 000 000 000 000 000 байтов
Поделитесь своими знаниями, ответьте на вопрос:
Склавиатуры вводится число(в диапазоне от -1 до 1вывести на экран является оно положительным, отрицательным или нулем(варианты ответа "positive", "negative", "zero"). напишите программу на с++
#include<iostream>
using namespace std;
void main()
{
setlocale(LC_ALL, "rus");
int num;
cout << "Введите число: ";
cin >> num;
if (num < 0)
cout << "NEGATIVE" << endl;
else
if (num > 0)
cout << "POSITIVE" << endl;
else
cout << "ZERO" << endl;
system("pause");
}