rusdtver
?>

Составить программу, по которой эвм формирует массив м(43), у которого всем элементам массива присваивания значение 18

Информатика

Ответы

dedald

program mass43;

const

N=43;

var

mass: array [1..N] of integer;

i: integer;

begin

 for i:=1 to N do

   mass[i]:=18;

   

   write('Наш массив: ',mass);

   

end.

Объяснение:

shchepinasm
#include <iostream>
using namespace std;
int main()
{ setlocale(0,"");
int a;
cout<<"введите значение погоды"<<endl;
cout<<"1-тепло"<<endl;
cout<<"2-жарко"<<endl;
cout<<"3-холодно"<<endl;
cout<<"4-колотун"<<endl;
cin>>a;
switch (a)
{
case 1: cout<<"вы можете одеть джинсы и футболку"<<endl; break;
case 2: cout<<"вы можете одеть шорты и майку "<<endl; break;
case 3: cout<<"вы можете одеть штаны и толстовку "<<endl; break;
case 4: cout<<"вы можете одеть куртку и свитер с подштанниками и ватными штанми "<<endl;
 break;
}
return 0;
}
alyans29
1. Если число в двоичной системе заканчивается на 00, значит оно кратно 4-м в десятичной системе. То есть нужно определить, сколько существует двузначных чисел, которые в квадрате кратны 4-м.10*10
Квадрат числа будет кратен четырем в том случае, если это число чётное, то есть ответом будет кол-во четных двузначных чисел, а это 45.

2. 3 бита это 2^3 = 1 из 8 вариантов. Значит четверки - это 1/8 от всех оценок, 64/8=8 четверок

3. Всего существует 5 четных цифр (включая 0). Из них можно составить 5^4 = 625 различных четырёхзначных комбинаций.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, по которой эвм формирует массив м(43), у которого всем элементам массива присваивания значение 18
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ehrik-ch
Низамов
werda84
gabbro19975650
TatianaSeliverstova64
info2471
shutovaa3471
mikhail
kronid12
ПодлеснаяМакарова1883
MislitskiiSergei1403
Radikovnanikolaeva
lobanosky162
Маргарита794
MonashevFesenko1483