nastya3213868
?>

Написать программу решения в паскале: у маши было а конфет и b яблок, у васи на k конфет больше и на n яблок меньше. найти сколько всего было у конфет и сколько яблок.

Информатика

Ответы

maksmi

program p1;

var a,b,k,n:integer;

begin

write ('Введите количество конфет у Маши ');

readln (a);

write ('Введите количество яблок у Маши ');

readln (b);

write ('Введите на сколько конфет больше у Васи ');

readln (k);

write ('Введите на сколько яблок меньше у Васи ');

readln (n);

write('Всего у ребят было ',a+a+k,' конфет и ',b+b-n,' яблок')

end.

Ионов202
//Сделал Лугачев Кирилл
//Специально для
//Все данные вводятся с клавиатуры
program Sravnenie;
var   
a, b: integer; // Стороны 1-ого прямоугольника 
d, c: integer;// Стороны 2-ого прямоугольника 
S1, S2: integer; // Площадь 
buf: integer;// Если площадь 1-ого будет меньше 2-ого                
                   //поменяем местами,что бы избавиться от минуса 
razn: integer; // Разница 2-ух площадей

begin   
Write('Введите стороны 1-ого прямоугольника: '); 
Readln(a, b);
   
Write('Введите стороны 2-ого прямоугольника: '); 
Readln(d, c);   
S1 := a * b; //Площадь 1-ого 
S2 := d * c; //Площадь 2-ого   
if S1 < S2 then  
begin   
buf := S1;   
S1 := S2;   
S2 := buf; 
end;   
razn := S1 - S2;    
Writeln('Площадь 1-ого больше площади 2-ого в - ',razn, ' раз');  
end.
Elen-Fler

Короче. Вот код.

def matrix_gen(gen, n, m):    Matrix = [];    for i in range(n):        a = [];        for j  in range(m):            a.append(gen[j]);        Matrix.append(a);    return Matrix;

Объяснение

Сначало ты инициализируешь функицю с названием "matrix_gen", которая принимает 3 параметра, 'gen' -- это генератор которые ты будешь использовать. 'n' & 'm' это размер матрицы.

Второй строчкой ты инициалихируешь пустой массив, которые похже заполнишь. Третей строчкой ты в for цикле обходишь все строки матрицы, они же подмассивы массива  Matrix, просто 'a'. Делаем мы это 'n' раз.

Четвётрой строчкой ты инициализируешь массив(ы, мы в цикле) 'a', и следующей строчкой заполняешь уже его. Так же в for цикле. Всего в нём будет 'm' элементов.

Надеюсь решение правильное. Честно говоря у тебя вопрос очень странно поставлен.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу решения в паскале: у маши было а конфет и b яблок, у васи на k конфет больше и на n яблок меньше. найти сколько всего было у конфет и сколько яблок.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Сопова
romka1210
kozhevniks
Татьяна
ВладимировнаАлександр1421
bristolhouse20151001
tigran87-87
aprelevka
Shamil
bel1-79
kosstroy
Оксана Николаевич
ksankaaleks611
semenovakotya577
julya847