xachen
?>

Составить программу для вычисления суммы кубов всех чисел от 1 до 10 , использовать while(​

Информатика

Ответы

Pirogovskii695

program kwad;  

var i,s:integer;  

begin

while i<>11 do begin

s:=s+sqr(i);

i+=1

end;  

writeln(s);  

end.

Бегун-Марина

1) 89₁₀ = 1011001₂

2) 600₁₀ = 100101100₂

3) 2010₁₀ = 11111011010₂

1) 513₁₀ = 1001₈

2) 600₁₀ = 1130₈

3) 2010₁₀ = 3732₈

Объяснение:

1)

89 / 2 = 44 + остаток 1

44 / 2 = 22 + остаток 0

22 / 2 = 11 + остаток 0

11 / 2 = 5 + остаток 1

5 / 2 = 2 + остаток 1

2 / 2 = 1 + остаток 0

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

89₁₀ = 1011001₂

2)

600 / 2 = 300 + остаток 0

300 / 2 = 150 + остаток 0

150 / 2 = 75 + остаток 0

75 / 2 = 37 + остаток 1

37 / 2 = 18 + остаток 1

18 / 2 = 9 + остаток 0

9 / 2 = 4 + остаток 1

4 / 2 = 2 + остаток 0

2 / 2 = 1 + остаток 0

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

600₁₀ = 100101100₂

3)

2010 / 2 = 1005 + остаток 0

1005 / 2 = 502 + остаток 1

502 / 2 = 251 + остаток 0

251 / 2 = 125 + остаток 1

125 / 2 = 62 + остаток 1

62 / 2 = 31 + остаток 0

31 / 2 = 15 + остаток 1

15 / 2 = 7 + остаток 1

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

2010₁₀ = 11111011010₂

1)

513 / 8 = 64 + остаток 1

64 / 8 = 8 + остаток 0

8 / 8 = 1 + остаток 0

1 / 8 = 0 + остаток 1

записываем остатки снизу вверх

513₁₀ = 1001₈

2)

600 / 8 = 75 + остаток 0

75 / 8 = 9 + остаток 3

9 / 8 = 1 + остаток 1

1 / 8 = 0 + остаток 1

записываем остатки снизу вверх

600₁₀ = 1130₈

3)

2010 / 8 = 251 + остаток 2

251 / 8 = 31 + остаток 3

31 / 8 = 3 + остаток 7

3 / 8 = 0 + остаток 3

записываем остатки снизу вверх

2010₁₀ = 3732₈

vasenkova1981

Первая задача:

class_a, class_b, class_c = int(input("Сколько детей в А классе? ")), int(input("Сколько детей в Б классе? ")), int(input("Сколько детей в В классе? "))

print("Для класса А нужно купить " + str(round(class_a / 2)) + " парт.\nДля Б " + str(round(class_b / 2)) + " парт.\nДля В " + str(round(class_c / 2)) + " парт.")

Объяснения:

Нам известно, что за каждой партой могут сидеть два ученика.

Чтобы узнать, сколько парт нам нужно купить для каждого класса, мы за количество учеников.

Дальше мы делим количество учеников каждого класса на два и округляем функцией round(число).

Вторая задача:

km = int(input("Сколько км машина проезжает в день?"))

path = int(input("Какова длина маршрута?"))

print("Машина проедет путь за " + str(path/km) + " дня(ей).")

Объяснения:

По условиям задачи запрашиваем, сколько км проезжает машина за день и длину маршрута.

Далее мы делим длину маршрута на км/день и получаем ответ на нашу задачу.

3ую задачу не решил, извиняюсь

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для вычисления суммы кубов всех чисел от 1 до 10 , использовать while(​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mariokhab
evageniy79
yliana
alexfold
dimaproh
Оксана Николаевич
nord248
Вагифович
irina-mic
dimaproh
delo1005
Bordo
Anna-Miron
peshnoshamon
kzhgutova