galinazajceva781
?>

Напишите программу которая печатает ваше имя в рамке из звездочекпаскальпример *витя*

Информатика

Ответы

petrakovao

это рамка у меня получилось

Объяснение

procedure Stars(str: integer);

  var

      i:integer;

  begin

      for i:=1 to str do  

          write('*');

  end;

egorova90356684858370
{ 1) Дан массив из десяти целых чисел. Определите, сколько элементов этого массива имеют максимальное значение. }
const n=10;
var 
  i,m,k: integer;
  var a: array[1..n] of integer;
begin
  m:=-1;
  writeln ('Исходный массив');
  for i:=1 to n do begin
    a[i]:=random(10);
    write (a[i]:3);
    if a[i]>m then m:=a[i];
  end;
  k:=0;
  for i:=1 to n do begin    
    if a[i]=m then k:=k+1;
  end;
  writeln;  
  writeln ('k = ',k);  
end.
--------------------------------------
Исходный массив
  0  9  6  1  2  9  6  7  4  7
k = 2
====================================

{ 2) В классе 20 учеников писали диктант по русскому. Написать программу и блок-схему подсчета кол-во оценок 2 3 4 5 получивших за диктант }
const n=20;
var 
  i,k2,k3,k4,k5: integer;
  var a: array[1..n] of integer;
begin
  k2:=0; k3:=0; k4:=0; k5:=0;
  writeln ('Массив оценок:');
  for i:=1 to n do begin
    a[i]:=random(2,5);
    write (a[i]:3);
    if a[i]=2 then k2:=k2+1 else
      if a[i]=3 then k3:=k3+1 else
        if a[i]=4 then k4:=k4+1 else k5:=k5+1;
  end;
  writeln;  
  writeln ('двоек = ',k2); 
  writeln ('троек = ',k3); 
  writeln ('четверок = ',k4); 
  writeln ('пятерок = ',k5); 
end.
------------------------------------
Массив оценок:
  4  4  4  3  5  2  2  4  4  3  4  4  4  4  4  3  4  4  4  3
двоек = 2
троек = 4
четверок = 13
пятерок = 1
============================================

{ 3)Объявлен набор в школьную баскетбольную команду. Известен рост каждого из n учеников желающих попасть в эту команду. 
Составьте алгоритм подсчета и блок схему количества претендентов имеющих шанс попасть в команду если рост игрока команды должен быть не менее 170 см.Считайте рост претендентов случайным числом из диапазона 150-200 см, а число претендентов n=50. }
const n=50; r=170;
var 
  i,k: integer;
  var a: array[1..n] of integer;
begin
  k:=0;
  writeln ('Массив - Рост претендентов:');
  for i:=1 to n do begin
    a[i]:=random(150,200);
    write (a[i]:5);
    if a[i]>=r then k:=k+1;
  end;
  writeln;  
  writeln ('Шанс попасть в команду имеют ',k,' претендентов');  
end.
------------------------------------------------
Массив - Рост претендентов:
 196  177  196  169  153  167  157  163  165  166  191  195  158  200  160  189  180  157  181  163  181  152  173  181  186  195  183  155  181  190  168  193  200  167  192  161  167  155  199  160  183  191  159  172  199  183  156  158  186  186
Шанс попасть в команду имеют 28 претендентов
===========================================
Написать программу и составить блок схему по этим : 1)дан массив из десяти целых чисел. определите,
Написать программу и составить блок схему по этим : 1)дан массив из десяти целых чисел. определите,
Написать программу и составить блок схему по этим : 1)дан массив из десяти целых чисел. определите,
amramzi
1)var
  a: array[1..10] of integer;
  m, i,s: integer;

begin
  randomize;
  for i := 1 to 10 do 
  begin
    a[i] := random(+10) + 1;
    if a[i] > m then m := a[i];
  end;
  for i := 1 to 10 do 
  begin
    if a[i]=m then s:=s+1;
  end;
  writeln(s);
end.
2)var

  a: array [1..20] of 2..5;  //Массив оценок учеников

  i: integer;

  n: array [2..5] of 2..5;  //Массив счетчиков оценок

 

begin

  for i:= 2 to 5 do   //Обнуляем счетчики оценок

    n[i]:= 0;

  for i:= 1 to 20 do   //Вводим оценки учеников и считаем их

  begin

    writeln('Введите оценку ', i, ' ученика');

    readln(a[i]);

    if a[i] = 2 then n[2]:= n[2] + 1;

    if a[i] = 3 then n[3]:= n[3] + 1;

    if a[i] = 4 then n[4]:= n[4] + 1;

    if a[i] = 5 then n[5]:= n[5] + 1;

  end;

  for i:= 2 to 5 do

    writeln('Количество получивших ', i, ' за диктант равно:  ', n[i]);  {Выводим значения счетчиков}

end.

3) Program zada4a3;
Var A: array[1..50] of integer; 
i,k:integer;
begin
for i:= 1 to 50 do
a[i]:= random(51)+150;
k:=0;
for i:= 1 to 50 do
if a[i]>170 then k:=k+1;
writeln(k);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая печатает ваше имя в рамке из звездочекпаскальпример *витя*
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yevgeniya Bessonov
Shamil
polikarpov-70
sebastianpereira994
nairahay
vdk81816778
Оксана Николаевич
Tyukalova
Ольга1915
Yarovitsin
dp199088206
IP1379
alexeytikhonov
com4047797
Алексей Ксения