set907
?>

Программа на языке python: составить программу, которая вычисляет кол-во двоек, троек, четверок, пятерок за контрольную работу. на вход программа получает сначала кол-во человек, затем поочередно вводятся оценки каждого ученика. пример: входные данные: 6 2 4 4 5 3 2 выходные данные: двоек - 2 троек - 1 четверок - 2 пятерок - 1

Информатика

Ответы

tefdst

1. Это двухмерный массив

(TypeError: unsupported operand type(s) for +=: 'int' and 'list')

2. 3x4 ([3][4])

3. Сложение элементов двумерного массива.

Только вот работать не будет, я полагаю здесь должны были складываться все элементы массивов, но на фото он прибавляет к переменной S не числа а массивы. И это выдаёт ошибку, так что...

Я бы сделал это так:

b = [[3, 5, 7, 78], [12, 10, 9, 56], [45, 31, 14, 23]]

s = 0

for i in b:

   for j in i:

       s += j

# Или используя len:

for i in range(len(b)):

   for j in range(len(i)):

       s += b[i][j]

print('s =', s)

# s = 293

YuREVICh646

Решение

Я бы расставил контрольные маршрутные точки, добавил к ним коллайдеры в виде триггеров. На них накинуть небольшой скрипт, говорящий какое действие нужно сделать, что бы попасть в следующую маршрутную точку(к примеру повернуть налево и продолжать идти). Когда NPC вступает с ним в коллизию(OnTriggerEnter), берет из него необходимые параметры для продолжения движения. Я так себе реализовывал.

Это если линейно и по кругу. А если рандомно передвижение по территории, то все с теми же контрольным точками, только нужно получить их все, выбрать случайную точку и обходом по графу идти до этой точки. Как только достиг, выбрал случайную следующую точку и пошел дальше.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программа на языке python: составить программу, которая вычисляет кол-во двоек, троек, четверок, пятерок за контрольную работу. на вход программа получает сначала кол-во человек, затем поочередно вводятся оценки каждого ученика. пример: входные данные: 6 2 4 4 5 3 2 выходные данные: двоек - 2 троек - 1 четверок - 2 пятерок - 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yamalsva45
Letajushaya362
MikhailovnaAnastasiya
dkvsadovoe
plio67380
Раисовна878
dilshermatov5806
Tamara
Coverplus30
vallihhh
Vyacheslavovna1108
zodgener
Olia72
Salkinserg
IP1379