thecoffeeowl
?>

1. напишите программу на языке паскаль, которая позволяет найти минимальное число массива х, состоящего из 30 элементов. 2. напишите программу на языке паскаль, которая позволяет найти сумму чисел массива х, состоящего из 20 элементов.

Информатика

Ответы

ea9824165833886

1.

program MinElement;

var

X: array[1..30] of Integer;

i, min: integer;

begin

randomize;

for i := 1 to 30 do

X[i] := random(100);

min := X[1];

for i := 1 to 30 do

if X[i] < min then

min := X[i];

writeln('Минимальное число: ', min);

write('Все элементы:');

for i := 1 to 30 do

write(' ', X[i]);

readln;

end.

2.

program Summa;

var

X: array[1..20] of Integer;

i, sum: integer;

begin

randomize;

for i := 1 to 20 do

X[i] := random(100);

sum := 0;

for i := 1 to 20 do

sum := sum + X[i];  

writeln('Сумма всех чисел: ', sum);

write('Все элементы:');

for i := 1 to 20 do

write(' ', X[i]);

readln;

end.

Всё правильно и проверено лично!

Allahverdi_Мария475
//Pascal ABC.NET 3.1 сборка 1256

Var
 s,s1:string;
begin
readln(s);
if (s[1]='в') and (s[2]=' ') then
 begin
  delete(s,1,1);
  s:='на'+s;
 end;
if (s[1]='В') and (s[2]=' ') then
 begin
  delete(s,1,1);
  s:='На'+s;
 end;
while pos(' в ',s)<>0 do
 begin
  if (s[1]='в') and (s[2]=' ') then
 begin
  delete(s,1,1);
  s:='на'+s;
 end;if (s[1]='В') and (s[2]=' ') then
 begin
  delete(s,1,1);
  s:='На'+s;
 end;
  s1:=s1+copy(s,1,pos(' в ',s)-1)+' на ';
  delete(s,1,pos(' в ',s)+2);
 end;
  if (s[1]='в') and (s[2]=' ') then
 begin
  delete(s,1,1);
  s:='на'+s;
 end;
if (s[1]='В') and (s[2]=' ') then
 begin
  delete(s,1,1);
  s:='На'+s;
 end;
s:=s1+s;
writeln(s);
end.

Пример ввода 1:
запасти в зиму, приехать в год, приготовить в день, выпить лекарство в ночь
Пример вывода 1:
запасти на зиму, приехать на год, приготовить на день, выпить лекарство на ночь

Пример ввода 2(глубокие песни современной отечественной эстрады):
В в в в в в в в в в в в в в в в в в н.
Пример вывода 2:
На на на на на на на на на на на на на на на на на на н.
restkof
// PascalABC.NET 3.1, сборка 1267 от 10.07.2016
const
  k=4; //количество классов
  u=18; // количество учеников в классе
var
  a:array[1..k,1..u] of real; // массив с ростом
  n:array[1..k] of integer; // массив результатов
  i,j:integer; // счетчики циклов
  m:real; // средний рост ученика в классе
begin
  for i:=1 to k do begin
    Writeln('Введите рост учеников ',i,'-го из классов');
    m:=0;
    for j:=1 to u do begin Read(a[i,j]); m:=m+a[i,j] end;
    m:=m/u;
    n[i]:=0;
    for j:=1 to u do
      if abs(a[i,j]-m)>5.0 then Inc(n[i]);
    end;
  Writeln('Количество учеников с ростом, отличающимся от среднего');
  Writeln('по каждому из классов более, чем на 5');
  for i:=1 to k do Write(n[i]:5)
end.

Пример решения для упрощенного случая, когда в классе на 18, а 5 учеников (чтобы меньше набирать)
Введите рост учеников 1-го из классов
168 174 181 172 175
Введите рост учеников 2-го из классов
162 173 170 158 183
Введите рост учеников 3-го из классов
157 185 159 168 167
Введите рост учеников 4-го из классов
170 173 176 168 171
Количество учеников с ростом, отличающимся от среднего
по каждому из классов более, чем на 5
    2    3    3    0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. напишите программу на языке паскаль, которая позволяет найти минимальное число массива х, состоящего из 30 элементов. 2. напишите программу на языке паскаль, которая позволяет найти сумму чисел массива х, состоящего из 20 элементов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dmitrievanata83538
vladimirdoguzov
ElenaEgorova1988576
megapolisgroup
Алексей Шуклин
elena
MonashevFesenko1483
aaltuxova16
Yuliya701
kuhonka2021
diana-kampoteks
Федоровна-Васильева
vasiliiparshin7668
uttgroup
Сергеевич1386