Shelchkowa453
?>

Объясните ! (через pascal abc) по данному натуральному числу n выведите такое наименьшее целое число k, что 2k≥n.операцией возведения в степень пользоваться нельзя! я нашла решение в интернете : var k, n, p: integer; begin readln (n) ; p: =1; while p begin p: =p*2; k: =k+1; end; writeln (k) ; end.но я не понимаю, почему там умножают на 2 и зачем плюс 1 и вообще что за что принимается, !

Информатика

Ответы

gbfedak220

объяснение:

//я так понял это :

твое решение скорее всего неверно. вот вообщем написал программу для решение данной :

var

  k, n: integer;

begin

  readln(n);   //вводим число n

  k : = 1;   //   k присвоил наименьшее

  repeat

    k : = k*2;   //умножение на 2 идет из условия 2*k> =n

  until k> =n ;

  writeln(k)  

end.

alazaref
Program egor_sasha; var num_eg, num_sash,pri,pri1: real; var mes_eg,mes_sash: real; beginwriteln('numer egora'); readln(num_eg); writeln('numer sashi'); readln(num_sash); writeln('mesto egora (verkh=1,vniz=0)'); readln(mes_eg); writeln('mesto sashi (verkh=1,vniz=0)'); readln(mes_sash); pri: =num_sash+1; pri1: =num_eg+1; if num_eg=pri then    writeln('yes')  else writeln('no'); if num_sash=pri1 then    writeln('yes')  else writeln('no'); if mes_eg=1 then    writeln('egor-high')else  writeln('egor-low'); if mes_sash=1 then    writeln('sasha-high')else  writeln('sasha-low'); end.
Cannabikh
Количество информации в сообщении обычно равно количеству бит (округляемому до ближайшего целого с избытком) , которое необходимо для воспроизведения текста сообщения. то есть в сообщении 10101010 информации - 8 бит, в сообщении "погода сегодня будет зимняя, снег не растает, солнце взойдет утром и сядет вечером" - 350 бит (если считать, для простоты, что в языке 32 буквы) . в сообщении e=hν информации, если кодировку ситать юникодом, - 8 байт (64 битa) информации. но вот ценность этих сообщений несопоставима.  но ценность информации не есть величина неизбывная и строго измеряемая для данного сообщения. она всегда зависит от того, кому эта информация предназначена, и от того, что путного можно извлечь из неё, а значит - слабо формализуема. в конце концов, запросто можно представить себе (путь и фантастическую) 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Объясните ! (через pascal abc) по данному натуральному числу n выведите такое наименьшее целое число k, что 2k≥n.операцией возведения в степень пользоваться нельзя! я нашла решение в интернете : var k, n, p: integer; begin readln (n) ; p: =1; while p begin p: =p*2; k: =k+1; end; writeln (k) ; end.но я не понимаю, почему там умножают на 2 и зачем плюс 1 и вообще что за что принимается, !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Kulikov1065
Anton661
zipylin
delta88
gulnaradjhumabaeva123
Написать программу в Python.
Dmitrievna-Dmitrii980
gaina6678
annanechaeva567
maltes
andreyshulgin835
cat2572066
АнтонАртем
Test Станислав
Zhamynchiev
Aleksandrova Zhanna1250