Konstantin_Vadimirovich
?>

Выведите на экран все числа от A до B включительно в порядке возрастания, с шагом C. Формат входных данных На вход программе дается три целых положительных числа A, B и C (0≤A, B, C≤105) . Формат выходных данных Вывести все цифры на одной строке через пробел Примечания Подсказка: Если A > B, значения A и B нужно поменять местами входные данные выходные данные 3 12 3 3 6 9 12 9 4 2

Информатика

Ответы

ValerevnaRustam1072

Код на языке python 3+

a = int(input())

b = int(input())

c = int(input())

for i in range(min(a,b),max(a,b) + 1,c):

   print(i, end = " ")

ninazholnerova9
Программа №1.

program НАЗВАНИЕ ПРОГРАММЫ;

{$APPTYPE CONSOLE}

uses
   SysUtils;
var
   a, b, h, s:real;
begin
   writeln('Enter a, b and h');
   readln(a, b, h);
      s:=(0.5*(a+b))*h;
   writeln('Area of the trapezoid=', s);
   readln;
end.

Программа №2.

program НАЗВАНИЕ ПРОГРАММЫ;

{$APPTYPE CONSOLE}

uses
   SysUtils;
var
   a, b, s:integer;
begin
   writeln('Enter the price and quantity');
   readln(a, b);
      s:=a*b;
   writeln('Cost of purchase=', s);
   readln;
end.

Программа №3.

program НАЗВАНИЕ ПРОГРАММЫ;

{$APPTYPE CONSOLE}

uses
   SysUtils;
var
   a, b, w:real;
begin
   writeln('Enter the speed and time');
   readln(a, b);
      w:=a*b;
   writeln('Way=', w);
   readln;
end.


Вместо "НАЗВАНИЯ ПРОГРАММЫ" напишите название Вашей программы.
Так как в некоторых задачах не оговорено, что числа целые или нет, я выбрал на всякий случай вещественный(real).
artmasterstyle
Var
a,b,c: integer;
x,y,z:string;
begin
x:='рубль';
y:='рубля';
z:='рублей';
writeln('Сколько стоит метр ткани?(в рублях)');
readln(a); writeln('Сколько вы хотите купить ткани?(в метрах квадратных)'); readln(b);
c:=a*b;
if c=1 then
begin
writeln('Это будет стоить',' ',c,' ',x);
end;
if (2<=c) and (c<=4) then
begin
writeln('Это будет стоить',' ',c,' ',y);
end;
if (5 <= c) and(c <= 1000000) then
begin
writeln('Это будет стоить',' ',c,' ',z);
end;
end.

В зависимости от результата программа будет выводить разное окончание.
1 рубль;
3 рубля;
100 рублей.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Выведите на экран все числа от A до B включительно в порядке возрастания, с шагом C. Формат входных данных На вход программе дается три целых положительных числа A, B и C (0≤A, B, C≤105) . Формат выходных данных Вывести все цифры на одной строке через пробел Примечания Подсказка: Если A > B, значения A и B нужно поменять местами входные данные выходные данные 3 12 3 3 6 9 12 9 4 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

РубенШафетдинов
tanu0618
AlekseiBunina1895
legezin
strager338
Хабарьева Андрей1056
viktorovna_Imamaevich679
juliapierrat
AMR89154331531
nmakarchuk
antoska391
rsd737
fox-cab3444
алексей-Ветошкин
irina-mic