delonghisochi
?>

Напишите программу В ПИТОНЕ! Напишите программу, в которой осуществляется ввод целых цисел(ввод осуществляется до тех пор, пока не будет введен ноль) и подсчет суммы и среднего арифметического введённых положительных чисел.

Информатика

Ответы

Андреевич

from statistics import mean

lst = []

x = int(input())

while x != 0:

   lst.append(x)

   x = int(input())

print('Сумма -> {} Среднее -> {}'.format(sum(lst), mean(lst)))

coffeenik20233

#arr = [*map(int, input().split(' 0')[0].split())]  если числа вводятся в строчку , то раскомментируйте и используйте эту строку, а инициализацию массива arr и цикл while закомментируйте

arr = []

while 1:

   tmp = int(input())

   if tmp != 0:  # Читаем сколько угодно чисел пока не будет ноль

       arr.append(tmp)

   else:

       break

s = 0  # сумма двузначных чисел

k = 0  # количество двузначных чисел

for i in arr:

   if 10 <= i <= 99:  # итерируемся по циклу и если число двузначное

       s += i  # то прибавляем его к сумме

       k += 1  # счетчик двузначный чисел увеличиваем на один

print(s/k) if k > 0 else print('NO') #если количество двузначных > 0 то выводим среднее арифметическое s/k, если нет то выводим NO

Taurus59707
Для того, чтобы перевести целое число из десятичной в двоичную систему счисления, необходимо разделить его на два, а затем делить на два каждое полученное частное до тех пор, пока не получится единица. Искомое двоичное число записывается как последовательность цифр, равных последнему частному (единице) и всем полученным остаткам, начиная с последнего.

Надо перевести сначала 21 в двоичную, потом 2 в двоичную и потом 2002 в двоичную

Получается вот так:
21 = 10101
2=10
2002 = 11111010010

В итоге:
10101.10.11111010010

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу В ПИТОНЕ! Напишите программу, в которой осуществляется ввод целых цисел(ввод осуществляется до тех пор, пока не будет введен ноль) и подсчет суммы и среднего арифметического введённых положительных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Михайловна-Гусева350
pifpaf85
Александрович_Викторовна
stperelyot7833
ananyananar
1) ? 2) ? 3) ? 4) ? 5) ? 6) ?
krikriska84
astenSA
zerckaln
VladimirovichKazakova1202
MAXIM76748
tofilev
Спивак
TatianaSeliverstova64
themolodoy
Klochkov malakhov1974