ognevasv555
?>

Напишите программу нахождения количества и суммы цифр целого положительного числа, используя для этого процедуру Sum(K, C, S), C - количество цифр целого положительного числа K, а S их сумма ( K — входной, C и S — выходные параметры целого типа Sample Input 1: 2651 Sample Output 1: 4 14 Sample Input 2: 67557 Sample Output 2: 5 30 Sample Input 3: 84717 Sample Output 3: 5 27

Информатика

Ответы

Корягина

program summa_i_kol_cifr;

var

x,s,k:integer;

begin

read(x);

s:=0;

k:=0;

while x>0 do

begin

s:=s+x mod 10;

k:=k+1;

x:=x div 10;

end;

write(k,' ',s)

end.

shuramuji

наибольшая поразрядная сумма может быть, если записаны три девятки, т.е. 27

2727 - удовлетворяет этому требованию. число 999999

277 - можно разбить только на 27'7. значит число имеет вид 999**. но сумма цифр 9** не может быть равна 7. не подходит.

2715 - разбиваем 27'15.
подходит. например, 99933

2730 - 27'30 не подходит

3027 - 30'27 не подходит

1527 - 15'27 подходит. например, 66999

727   - разбивается только на 7'27. значит, последние - три девятки. число **999. сумма цифр **9 не может быть равна 7. не подходит

512   -
 

orion-inginiring7807
1)194:
Пример:4199(Сумма нечетных=19,сумма четных=4.В порядке убывания)"+"
2)1913(Должна быть хотя бы одна цифра четная)"-"
3)1420(Цифры не в порядке убывания.) "-"
4)1118:
Нам нужно получить четное число 18:
a)Пусть нечетные цифры = 9,9.Но тогда у нас остались четные числа,но мы никак не сможем получить 11.
b)Чтобы получить 18 из четных чисел нужно,чтобы числа = 8,8,4(максимум),но тогда мы не сможем получить 11,т.к. максимальная цифра=9.Значит "-"
5)1212
Пример:5766(Сумма четных=12(6+6),сумма нечетных=12(5+7)) "+"
6)205
Нам нужно получить 20:
Мы не сможем получить 20 из нечетных чисел,т.к. из нечетных чисел нам нужно получить 5.
Максимальные цифры из четных равны=8,8,4.(20).
И одна цифра нечетная:5.Пример:8548 "+"
7)420:
Пусть нам нужно получить 42,но мы не сможем получить данную сумму,т.к. максимум=36(9,9,9,9) "-"
8)294:
Пусть одна из цифра=4,т.е. остальные у нас нечетные.Опять же максимальная сумма=27(9,9,9).Значит "-"
9)55:
Должна быть хотя бы одна цифра четная."-"
ответ: 3 числа

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу нахождения количества и суммы цифр целого положительного числа, используя для этого процедуру Sum(K, C, S), C - количество цифр целого положительного числа K, а S их сумма ( K — входной, C и S — выходные параметры целого типа Sample Input 1: 2651 Sample Output 1: 4 14 Sample Input 2: 67557 Sample Output 2: 5 30 Sample Input 3: 84717 Sample Output 3: 5 27
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Suralevartem
nunabat457
polina0075880
Геннадьевна
Pgr100
panasenko68
Olesyamilenina8
girra
Елена
АлексейГагиковна1774
Pautova1119
yuraotradnov
saryba
colus77
tyrenumberone