Екатерина655
?>

2) Составить алгоритм и написать программу, которая заполняет массив из 5 элементов случайными числа от 1 до 10 и находит произведение всех элементов массива

Информатика

Ответы

sanina611

===== PascalABC.NET =====

begin

 var a := ArrRandom(5, 1, 10);

 a.Println.Product.Print

end.


2) Составить алгоритм и написать программу, которая заполняет массив из 5 элементов случайными числа
sklad2445

Будет выведено: sr=4.5

Объяснение:

Расписал подробно и с комментариями.

program a78;  //Название программы

var i,s:integer; sr:real;  //Объявление переменных

const a:array [1..6] of integer = (1,7,3,6,0,10);  //объявление массива

 

 begin //тело программы

  s:=0;  //присваиваем s к 0, своеобразный буфер

  for i:=1 to 6 do  //для значений i от 1 до 6 выполняй следующие действия:

    s:=s+a[i];  //тело цикла, то что будет циклиться и выполняться

  sr:=s/6;  //тело цикла, то что будет циклиться и выполняться

  writeln('sr=',sr);   //вывод значения

end.  //конец программы

vvk2008

Будет выведено: sr=4.5

Объяснение:

Расписал подробно и с комментариями.

program a78;  //Название программы

var i,s:integer; sr:real;  //Объявление переменных

const a:array [1..6] of integer = (1,7,3,6,0,10);  //объявление массива

 

 begin //тело программы

  s:=0;  //присваиваем s к 0, своеобразный буфер

  for i:=1 to 6 do  //для значений i от 1 до 6 выполняй следующие действия:

    s:=s+a[i];  //тело цикла, то что будет циклиться и выполняться

  sr:=s/6;  //тело цикла, то что будет циклиться и выполняться

  writeln('sr=',sr);   //вывод значения

end.  //конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

2) Составить алгоритм и написать программу, которая заполняет массив из 5 элементов случайными числа от 1 до 10 и находит произведение всех элементов массива
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vasilevam
zubareva23338
thecoffeeowl
zatoichi69
skvorec3424
many858
Serdechnaya636
yurkovam-037
Fomin Korablev1781
titancore
Бернард pokerman
Leobed917670
len4ik1986
msk27
saint158
▲