?>
1. Напишите программу, которая заполняет массив из N = 8 элементов случайными числамив диапазоне (0, 10), выводит его на экран, а затем выводит на экран квадраты всех элементовмассива.Пример:Массив: 5 6 2 3 1 4 8 7Квадраты: 25 36 491 16 64 49.
Ответы
C# 8.0:
using System;
...
var Arr = RandomIntArr(0,10,8);
foreach(int i in Arr) Console.Write(i+" ");
Console.WriteLine();
foreach(int i in Arr) Console.Write(i*i + " ");
...
static int[] RandomIntArr(int Min, int Max, int ArrLen) {
Random rnd = new Random();
int[] Out = new int[ArrLen];
for (int i = 0; i < ArrLen; i++) Out[i] = rnd.Next(Min, Max+1);
return Out;
}