armusaeff
?>

Напишите программу для исполнителя робот рисующего букву н используя цикл с параметром начальное положение робота - левый верхний угол

Информатика

Ответы

missbuhgalter2013
Program pr2;
uses crt;
var
m,n,i,j,k,l:integer;
mas: array[1..99,1..99] of integer;
masb: array [1..99] of integer;
begin
clrscr;
write('vvedite m');
readln(m);
write('vvedite n');
readln(n);
writeln('vvedite massiv MxN')
;for i:=1 to m do
for j:=1 to n do
begin
write('mas[',i,',',j,']= ');
readln(mas[i,j]);
end;
for i:=1 to m do
begin
k:=mas[i,1];
l:=mas[i,1];
for j:=1 to n do
begin
if k < mas[i,j] then k:=mas[i,j];
if l > mas[i,j] then l:=mas[i,j];
end;
masb[i]:=k-l;

end;
for i:=1 to m do
begin
for j:=1 to n do
write(mas[i,j],' ');
writeln('result = ',masb[i]);
end;
readln(i)
end.
ilplakhotin8734
Прямые параллельны между собой, если частное коэффициентов у X и Y равны.
Коэффициент - это числовой множитель в алгебраическом выражении.*
Посчитаем их.

7x + 6y + 9 = 0
У этого уравнения коэффициент у X - 7, а у Y - 6
их частное - это \frac{7}{6}

5x + 7y + 14 = 0
Тут коэффициенты X, Y это 5 и 7
их частное - \frac{5}{7}

8x + 6y + 19 = 0
Тут коэффициенты X, Y это 8 и 6
их частное - \frac{8}{6}
сократим дробь на 2, получим \frac{4}{3}

15x + 21y + 22 = 0
Тут коэффициенты X, Y это 15 и 21
их частное - \frac{15}{21}
сократим дробь на 3, получим \frac{5}{7}

10x + 14y + 4 = 0
Тут коэффициенты X, Y это 10 и 14
их частное - \frac{10}{14}
сократим дробь на 2, получим \frac{5}{7}

И того у нас получилось 3 равные дроби, это и есть те уравнения.
5x + 7y + 14 = 0
15x + 21y + 22 = 0
10x + 14y + 4 = 0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для исполнителя робот рисующего букву н используя цикл с параметром начальное положение робота - левый верхний угол
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Михайловна-Гусева350
по инфе, тут таблица по exele​
moonligh3560
arevik2307
Дмитрий_Евлампиев518
alexandrxzx09
lagutkins
borisrogovpr3407
Александр
gelena03
oloinics
Шуршилина_Ильич
Шеина
info22
Gpack54
BekturMagometovich189