ayanrsadykov
?>

Ниже приведена программа на языке Python: x = int(input()) a= x//10//10 %10 b=x//10%10 c=x%10 print(с, a, b) В качестве исходных данных вводится трёхзначное число. Переменной х присваивается введённое значение Значения переменных a, b и с вычисляются в программе с операций целочисленного деления и операции вычисления остатка. При одном из запусков программы было введено число 538. 1) Чему будет равно значение переменной а? 2) Чему будет равно значение переменной b? 3) Чему будет равно значение переменной c? 4) Какой результат выведет программа? 5) Составить блок-схему к этой программе

Информатика

Ответы

lk1303

1) 5

2) 3

3) 8

4) 5 3 8

Evsevia-a
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var a:=ReadLines('m17.txt').JoinIntoString.ToIntegers;
  a.Println;
  var b:=a.Select((x,i)->Rec(x,i)).Where(x->x.Item1<0)
    .Select(x->x.Item2).ToArray;
  if b.Count<>2 then
    Writeln('Количество отрицательных элементов не равно двум')
  else begin
    a:=SeqFill(b[0],0).Concat(a.Skip(b[0]).Take(b[1]-b[0]+1))
      .Concat(SeqFill(a.Length-b[1]-1,0)).ToArray;
    a.Println
    end
end.

Тестовое решение:
23 14 7 15 0 13 -6 41 18 13 8 42 27 -11 3 19 10
0 0 0 0 0 0 -6 41 18 13 8 42 27 -11 0 0 0

Файл с исходными данными имеет имя m17.txt. Тестовый файл находится во вложении. Разбивка на строки сделана по 5 значений, но может быть совершенно произвольной. Также нет привязки именно к 17 числам, главное - чтобы отрицательных чисел было ровно два, иначе будет выдано сообщение о их неверном количестве.
Мартынова1638
Под угрозой информационной безопасности принято понимать потенциально возможные действия, явления или процессы оказать нежелательное воздействие на систему или на хранящуюся в ней информацию.Такие угрозы, воздействуя на ресурсы, могут привести к искажению данных, копированию, несанкционированному распространению, ограничению или блокированию к ним доступа. В настоящее время известно достаточно  большое количество угроз, которые классифицируют по различным признакам.По природе возникновения различают естественные и искусственные угрозы. К первой группе относятся те, что вызваны воздействием на компьютерную систему объективных физических процессов или стихийных природных явлений. Вторая группа – те угрозы, которые обусловлены деятельностью человека.По степени преднамеренности проявления, угрозы разделяют на случайные ипреднамеренные.Также есть разделение в зависимости от их непосредственного источника, в качестве которого может выступать природная среда (например, стихийные бедствия), человек (разглашение конфиденциальных данных), программно-аппаратные средства: санкционированные (ошибка в работе операционной системы) и несанкционированные (заражение системы вирусами).Источник угроз может иметь разное положение. В зависимости от этого фактора также выделяют три группы:- Угрозы, источник которых находятся вне контролируемой группы компьютерной системы (пример – перехват данных, передаваемых по каналам связи)- Угрозы, источник которых – в пределах контролируемой зоны системы (это может быть хищение носителей информации)- Угрозы, находящиеся непосредственно в самой системе (например, некорректное использование ресурсов).Угрозы по-разному воздействовать на компьютерную  систему.  Это могут быть пассивные воздействия, реализация которых не влечет за собой изменение структуры данных (например, копирование). Активные угрозы — это такие, которые, наоборот, меняют структуру и содержание компьютерной системы (внедрение специальных программ).В соответствии с разделением угроз по  этапам доступа пользователей или программ к ресурсам системы существуют  такие опасности, которые проявляются на этапе доступа к компьютеру и обнаружимые после разрешения доступа (несанкционированное использование ресурсов).Классификация по месту расположения в системе подразумевает деление на три группы: угрозы доступа к информации, находящейся на  внешних запоминающих устройствах, в оперативной памяти и к той, что циркулирует в линиях связи.ОТВЕТ ВЗЯТ ИЗ ИНТЕРНЕТА!!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ниже приведена программа на языке Python: x = int(input()) a= x//10//10 %10 b=x//10%10 c=x%10 print(с, a, b) В качестве исходных данных вводится трёхзначное число. Переменной х присваивается введённое значение Значения переменных a, b и с вычисляются в программе с операций целочисленного деления и операции вычисления остатка. При одном из запусков программы было введено число 538. 1) Чему будет равно значение переменной а? 2) Чему будет равно значение переменной b? 3) Чему будет равно значение переменной c? 4) Какой результат выведет программа? 5) Составить блок-схему к этой программе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

antongenfon
nastya3213868
elenaftdv7
SAMSCHOOL96
Platon
arina2403423
АлександровнаВладлен243
appbiznessm
satinvova
Veronika1270
Вадимовна
podenkovaev314
dinadumno2114
sredova71121