Nazart44446
?>

Составьте программу, которая выводит четные числа от 2 до 40 в строку , через запятую ​

Информатика

Ответы

rudakovam198

(см. объяснение)

Объяснение:

program task;

var i: integer;

begin

for i:= 2 to 39

do if(i mod 2 = 0) then write(i, ',');

writeln(40);

end.

rytikovabs

Алгоритм такой:

1 шаг: определяем сколько мы получим денег за первые 75 газет.

Пусть n - всего газет, тогда (n-(n-75))*F = A, - рублей за первые 75 газет.

2 шаг: определяем кол.во копеек, которые мы получим за остальные газеты: (n-75)*X = B, - копеек.


Программа на естественном языке:

Переменные:

A, B : целые;

Начало

Введение n (число газет);

Введение F(цена за первые 75 газет);

Введение X(цена за последующие газеты);

A присвоить (n-(n-75))*F;

B присвоить (n-75)*X;

Вывод (Мальчик заработает A рублей B копеек).

Конец.

ea-office
((3 + 1) * 3) * 3 = 36 ((3) * 3 + 1 + 1 + 1) * 3 = 36 ((3) * 3 + 1 + 1) * 3 + 1 + 1 + 1 = 36 ((3) * 3 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1) * 3 = 36 ((3) * 3) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3 + 1) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 (3) * 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 3 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 + 1 = 36 ответ 16 def f0(number, log) #   v = 1   n = number + v   log += " + #{v}"   # log += "[" + n.to_s + "] "   return [n, log] end def f1(number, log) #   v = 3   n = number * v   log = "(#{log}) * #{v}"   # log += "[" + n.to_s + "] "   return [n, log] end def countways(start_num, end_num, op_numbers, max_steps = 0)   ways = {}   ways.store(start_num.to_s, start_num)   max_steps = max_steps == 0 ? (start_num - end_num).abs : max_steps   count = 0   for steps in 1..max_steps           # puts "steps = #{steps}"           new_ways = {}           ways.each_pair{|log, num|                   for k in 0..op_numbers-1                           num1, log1 = f0(num, log) if k == 0                           num1, log1 = f1(num, log) if k == 1                           num1, log1 = f2(num, log) if k == 2                           if num1 == end_num                                   # and log.include? ('[8]')                           then                                   log1 += " = " + end_num.to_s                                   count += 1                                   puts log1                           elsif num1.between? (start_num, end_num)                                   new_ways.store(log1, num1)                           else                                   # log1 = log1 + " = " + num1.to_s + " bad "                                   # puts log1                           end                   end           }           # p [steps, ways.size, new_ways.size]           ways = new_ways   end   return count end

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая выводит четные числа от 2 до 40 в строку , через запятую ​
Ваше имя (никнейм)*
Email*
Комментарий*