diana-020
?>

Напишите программу для счета мелких денег. Она должна спрашивать: «Сколько у вас монет по 50 копеек?»; «Сколько у вас монет по 10 копеек?»; «Сколько у вас монет по 5 копеек?»; «Сколько у вас монет по 1 копейке?». После этого на экране должна появиться общая сумма. Пример входа: Сколько у вас монет по 50 копеек? 10 Сколько у вас монет по 10 копеек? 10 Сколько у вас монет по 5 копеек? 10 Сколько у вас монет по 1 копеек? 10 Пример результата: Всего у вас 660 копеек. НА ПИТОНЕ

Информатика

Ответы

Кононова-БЕСКРОВНАЯ

program p1;

uses crt;

var a,b,c,d,e,s:integer;

begin

a:=50;

b:=10;

c:=5;

d:=1;

writeln('сколько у вас монет по 50');

read(e);

s:=a *e;

writeln('сколько у вас монет по 10');

read(e);

s:=s+b*e;

writeln('сколько у вас монет по 5');

read(e);

s:=s+c*e;

writeln('сколько у вас монет по 1');

read(e);

s:=s+d*e;

write('Всего копеек ',s);

end.

Подробнее - на -

Объяснение:

jakushkinn
Программы из 5 команд и результаты их выполнения:
11111: 7^5 * 2^5 = 16807 * 32 = 537824
11112: 7^5 / 7 * 2^4 = 2401 * 2^4 = 38416
11122: 7^5 / 7^2 * 2^3 = 343 * 8 = 2744
11222: 7^5 / 7^3 * 2^2 =  49 * 4 = 196
12222: 7^5 / 7^4 * 2 = 7 * 2 = 14
22222:  7^5 / 7^5 = 1
(Сами числа вычислять не обязательно)
Все другие программы будут давать в результате одно из перечисленных выше значений. Например, результат программы 12121 = результату программы 11122:
7^5 * 2 / 7 * 2 / 7 * 2 = 7^5 / 7^2 * 2^3
ответ: количество различных чисел = 6
Igor120
ТЕРЕМОК на новый лад (информатика)

СТОИТ В ЛЕСУ ТЕРЕМОК
МИМО ШЕЛ СИСТЕМНЫЙ БЛОК

ПОСТУЧАЛСЯ
– НЕТ ОТВЕТА

И РЕШИЛ ОН - ТАК И БЫТЬ
БУДУ САМ Я В ДОМЕ ЖИТЬ

ПРОВОДА СВОИ ДОСТАЛ
И В ТЕРЕМОК ИХ ЗАПИХАЛ.

ВОТ СТОИТ ОН СРЕДИ ЛЕСА
А НАВСТРЕЧУ МОНИТОР:

- О, ЗДОРОВО, БЛОК СИСТЕМНЫЙ

МОЖНО МНЕ С ТОБОЮ ЖИТЬ
БУДЕМ ДОЛГО МЫ ДРУЖИТЬ? !

- ДА, КОНЕЧНО, ЗАХОДИ
ТОЛЬКО СИЛЫ БЕРЕГИ

ЗНАЙ! НАГРУЗКА НА ТЕБЯ
ОЧЕНЬ СИЛЬНАЯ ЛЕГЛА

ВОТ, ЖИВУТ ОНИ, НО ЧТО-ТО…
НЕ ХВАТАЕТ ИМ КОГО – ТО

ТАК РЕШИЛ СИСТЕМНИК ШНУРОВ
ВДРУГ, ИДЕТ КЛАВИАТУРА

- О, Я ТОЖЕ К ВАМ ХОЧУ
Я ДЕТИШЕК НАУЧУ
НА КОМПЬЮТЕРЕ ПЕЧАТАТЬ

И ………

НЕ УСПЕЛА ОНА СКАЗАТЬ,
КАК ТУТ ПРИШЕЛ МОДЕМ
ОПЯТЬ:

- ПОДКЛЮЧУ ВАС К ИНТЕРНЕТУ
ВСЕ ПРОЧИТАЮТ СКАЗКУ ЭТУ!

ВОТ ИХ ЧЕТВЕРО ЖИВЕТ
ИЗДАЛЕКА ПРИНТЁР ИДЕТ

- РАСПЕЧАТАЮ Я ВАМ
ВАШУ СКАЗКУ ПО СЛОГАМ.

ВОТ ИХ ПЯТЕРО ТЕПЕРЬ,
НО СКРИПИТ В ПРИХОЖЕЙ ДВЕРЬ

И ЗАХОДИТ МЫШКА К НИМ
С ДЛИННЫМ ХВОСТИКОМ
СВОИМ

К БЛОКУ МЫШКА ПОДОШЛА
И СВОЙ ХВОСТИК ОТДАЛА

ПРОВОДА ВСЕ
ПОДКЛЮЧИЛИ
И КОМПЬЮТЕР
ПОЛУЧИЛИ!! !

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для счета мелких денег. Она должна спрашивать: «Сколько у вас монет по 50 копеек?»; «Сколько у вас монет по 10 копеек?»; «Сколько у вас монет по 5 копеек?»; «Сколько у вас монет по 1 копейке?». После этого на экране должна появиться общая сумма. Пример входа: Сколько у вас монет по 50 копеек? 10 Сколько у вас монет по 10 копеек? 10 Сколько у вас монет по 5 копеек? 10 Сколько у вас монет по 1 копеек? 10 Пример результата: Всего у вас 660 копеек. НА ПИТОНЕ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anatolevich1506
Новиков1139
ЕлизаветаВладимирович
Шиморянов Мария1866
pechyclava
An-solomon
taa19707470
Shaubnatali
Надья-Олеговна
АлександровнаВладлен243
Нарисовать с цикла и переменными
mac4roc3781
AMR89154331531
Postnikova-StreltsovaKyulbyakova
pk199888
samoilovcoc