Shamil
?>

Диск стоит Х рублей. У вас имеется А рублей. Хватит ли вам денег на покупку диска? В программе предусмотрите вывод фраз «ДА» или «НЕТ». В случае недостатка, определите сколько денег надо добавить. РЕШИТЬ С

Информатика

Ответы

Galinova2911

input "цена диска:", x

input "сбережения: ", a

if x <= a then

print "ДА"

else

z = x - a

print "НЕТ"

print "Вам не хватает ", z, " рублей."

end if

shajmasha

ответ :MacBook Air — сверхтонкий ноутбук серии MacBook Apple, выпускаемый в двух вариантах: с 11,6- и 13,3-дюймовыми экранами.  

Apple MacBook Pro — ноутбук компании Apple. Позиционируется Apple как ноутбук для профессиональной деятельности — или вместо стационарного компьютера.  

Retina (от англ. retina — сетчатка) — общее маркетинговое название ЖК-дисплеев используемых в устройствах Apple и отличающиеся высокой плотностью пикселей. Опираясь на исследования, что человеческий глаз может различить только 300 ppi, производитель заявляет что на таких дисплеях пикселизация изображения неразличима глазом  

Объяснение:Из всего выше сказанного мною, берите Apple MacBook Pro, так как в MacBook Air встроенная видеокарта т. е она интегрированная. Как правило ноутбуки оснащаются одним интегрированным или дискретным графическим контроллерами. В последнее время в ноутбуках все чаще можно встретить комбинированную графику. В таких ноутбуках одна графика интегрированная в процессор или чипсет, а вторая дискретная. В зависимости от запускаемого на ноутбуке приложения может использоваться разные графические контроллеры. Так при работе с офисными программами, используется интегрированная графика, а при запуске игр задействуется дискретная. Такая комбинация позволяет увеличить продолжительность работы ноутбука.

АлександрАлина

var

 n,k:integer;

 a:array of integer;

 s,k2:real;

begin

 

 {Ввод размера массива и элементов массива}

 while n<3 do begin

   write('Введите размер массива - '); readln(n);

   if n<3 then writeln('[Массив слишком короткий]');

 end;

 setLength(a,n);

 for var i1:=0 to n-1 do begin

   write('Введите ',i1+1,' элемент массива - '); readln(a[i1]);

 end;

 

 {Вычесление минимальной суммы трёх соседних элементов массива}

 s:=a[0]+a[1]+a[2];

 for var i2:=2 to n-2 do begin

   k:=a[i2-1]+a[i2]+a[i2+1];

   if s>k then s:=k;

 end;

 writeln('Минимальная сумма трёх соседних элементов = ',s);

 

 {Выполнение условия чётности и нечётности}

 k2:=s;

 while k2>=2 do begin

   k2:=k2-2;

 end;

 if k2=0 then s:=sqr(s)

 else s:=sqrt(s);

 write('ответ: ',s:0:3);

 

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Диск стоит Х рублей. У вас имеется А рублей. Хватит ли вам денег на покупку диска? В программе предусмотрите вывод фраз «ДА» или «НЕТ». В случае недостатка, определите сколько денег надо добавить. РЕШИТЬ С
Ваше имя (никнейм)*
Email*
Комментарий*