besson89
?>

(НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON) Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 2. (НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON)

Информатика

Ответы

Картузов-Алексей1252

summ = 0

a = int(input())

while a != 0:

   if a % 7 == 0 and a % 10 == 2:

       summ += a

   a = int(input())

print(summ)

atupicyn754

На панели «Свойства» в Illustrator можно просматривать настройки и элементы управления для текущей задачи или рабочего процесса. Эта панель была реализована с целью повышения удобства работы, чтобы предоставить пользователю доступ к необходимым элементам управления тогда, когда это необходимо.

Панель «Свойства» по умолчанию отображается в рабочей среде «Основные настройки». К ней также можно перейти, выбрав Окно > Свойства.

Часто используемые элементы управления панели «Свойства» отображаются на переднем плане. К остальным элементам управления можно перейти, нажав значок троеточия в правом нижнем углу либо подчеркнутую опцию

Объяснение:

можно лучший ответ

Petrushin482

События – это действия, совершаемые пользователем или операционной системой.

Например:

действия пользователя – нажатие клавиши на клавиатуре, щелчок мыши и т.д.;

действия операционной системы – активизация окна, посылка сигнала таймера и т. д.

При возникновении события Windows посылает соответствующее сообщение, которое может быть воспринято и обработано программой.

В Pascal Windows Forms каждому событию присвоено имя. Например, щелчок кнопкой мыши – это событие Click,  нажатие клавиши клавиатуры -  KeyPress.

Реакцией на событие должно быть какое-либо действие. Реакция на событие реализуется как процедура обработки события (обработчик события). Таким образом, для того чтобы программа выполняла некоторую работу в ответ на действия пользователя, программист должен написать процедуру обработки соответствующего события.

Событие Назначение

Click Происходит, когда пользователь выбирает элемент управления с одинарного щелчка кнопкой мыши

Changed Происходит при изменении значения в элементе управления

KeyPress Происходит, когда пользователь нажимает любую клавишу символа  на клавиатуре, кроме функциональных и клавиш управления курсором

KeyUp Происходит, когда пользователь отпускает клавишу (Up - вверх)

KeyDown Происходит при нажатии пользователем какой-либо клавиши (включая вс и функциональные Ctrl, Alt, Shift) в тот момент, когда ЭУ находится в фокусе (Down -вниз)

MouseUp Происходит при отпускании кнопки мыши  

MouseDown Происходит при нажатии кнопки мыши  

MouseMove Происходит при перемещении указателя мыши над элементом управления

DoubleClick Происходит, когда пользователь выбирает элемент управления с двойного щелчка кнопкой мыши

Процедуры обработки событий (Обработчики событий)  – это подпрограммы (фрагменты программы), задающие действия, которые приложение должно выполнить в ответ на какое-то событие.

Написание процедуры обработки события

Выделить элемент управления.

Перейти на страницу События Инспектора Объектов.

Выделить нужное событие.

Дважды щелкнуть по белому полю перед названием события, при этом автоматически создается шаблон для обработчика события.

Написать код, который должен выполняться в ответ на это событие между begin и end.

Объяснение:

Події-це дії, що здійснюються користувачем або операційною системою.

Наприклад:

дії користувача-натискання клавіші на клавіатурі, клацання миші і т. д.;

дії операційної системи-активізація вікна, посилка сигналу таймера і т. д.

При виникненні події Windows посилає відповідне повідомлення, яке може бути сприйнято і оброблено програмою.

У Pascal Windows Forms кожній події присвоєно ім'я. Наприклад, клацання кнопкою миші-це подія Click, натискання клавіші клавіатури-KeyPress.

Реакцією на подію має бути будь-яка дія. Реакція на подію реалізується як процедура обробки події (обробник події). Таким чином, для того щоб програма виконувала деяку роботу у відповідь на дії користувача, програміст повинен написати процедуру обробки відповідної події.

Подія Призначення

Click відбувається, коли користувач вибирає елемент управління за до одинарного клацання кнопкою миші

Changed відбувається при зміні значення в елементі управління

KeyPress відбувається, коли користувач натискає будь-яку клавішу символу на клавіатурі, крім функціональних і клавіш управління курсором

KeyUp відбувається, коли користувач відпускає клавішу (Up-вгору)

KeyDown відбувається при натисканні користувачем будь-якої клавіші (включаючи допоміжні і функціональні Ctrl, Alt, Shift) в той момент, коли ЕУ знаходиться у фокусі (Down-вниз)

MouseUp відбувається при відпуску кнопки миші

MouseDown відбувається при натисканні кнопки миші

MouseMove відбувається при переміщенні покажчика миші над елементом управління

DoubleClick відбувається, коли користувач вибирає елемент управління за до подвійного клацання кнопкою миші

Процедури обробки подій – обробники подій)-це підпрограми (фрагменти програми), що задають дії, які програма повинна виконати у відповідь на якусь подію.

Написання процедури обробки події

Виділити елемент керування.

Перейти на сторінку події Інспектора Об'єктів.

Виділити потрібну подію.

Двічі клацнути по білому полю перед назвою події, при цьому автоматично створюється шаблон для обробника події.

Написати код, який повинен виконуватися у відповідь на цю подію між begin і end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

(НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON) Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 2. (НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nkochladze
Araevich
euzdenova
partners
Vladimirovna1858
luksorsps20096124
hello
orinvarostov
yelenaSmiryagin
Кристина910
shkola8gbr
oaved2018
Advantage9111
Анатольевич-Фатима
sergey