blackpoint2020273
?>

Напишите программу для исполнителя Чертежник Используйте алгоритмическую конструкцию Цикл

Информатика

Ответы

barabanoveugeny

Python

Объяснение:

код:

import random

n = random.randint(10, 100)

t = []

p = []

for i in range(1, n):

   if n % i == 0:

       i = str(i)

       t += i

       i = int(i)

       for k in range(2, i):

           if i % k == 0:

               i = str(i)

               p += i

               break

t = list(map(int, t))

p = list(map(int, p))

for x in p:

   if x in t:

       t.remove(x)

t.remove(1)

if len(t) == 0:

   t.append(n)

   print(*t)

else:

   s = [str(x) for x in t]

   print('simple', '(', n, ')', '=', *s)

armentamada1906

Python

Объяснение:

код:

import random

n = random.randint(10, 100)

t = []

p = []

for i in range(1, n):

   if n % i == 0:

       i = str(i)

       t += i

       i = int(i)

       for k in range(2, i):

           if i % k == 0:

               i = str(i)

               p += i

               break

t = list(map(int, t))

p = list(map(int, p))

for x in p:

   if x in t:

       t.remove(x)

t.remove(1)

if len(t) == 0:

   t.append(n)

   print(*t)

else:

   s = [str(x) for x in t]

   print('simple', '(', n, ')', '=', *s)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для исполнителя Чертежник Используйте алгоритмическую конструкцию Цикл
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kazanoop
vipppp19743355
ainud
dvpered
bal4shovser16
muziumednogorsk
Fetyukov
Прошкин_Николай368
nadejdashin508
ilyushin-e
oxy03214428
Алексеевна_Валентиновна
АлексейГагиковна1774
За спам сразу бан , так что без этого
sergeev-alp5
okunevo2010