ainud
?>

1) Даны три целых числа. Выбрать из них те, которые принадлежат отрезку [1, 3]. (Условный оператор) 2) Даны 2 стороны. Составить программу, которая по введенному значению 1, 2, 3 вычисляет: 1: Площадь прямоугольника 2: Периметр прямоугольника 3: Диагональ прямоугольника. (Множественный выбор) 3) Найти сумму ряда S=1+3+5+...+99. (Циклы)

Информатика

Ответы

Boyaris

Задача 1:

program HW1;

var a,b,c:integer;

begin

   write('Ведите три целых числа через пробел: '); readln(a,b,c);

   write('Числа, попадающие в отрезок [1,3]: ');

   if (a >= 1) and (a <= 3) then write(a, ' ');

   if (b >= 1) and (b <= 3) then write(b, ' ');

   if (c >= 1) and (c <= 3) then write(c, ' ');

end.

Задача 2:

program HW2;

var a,b:real;

var c:integer;

begin

   write('Ведите две стороны прямоугольника через пробел: '); readln(a,b);

   writeln('Что трубуется вычислить?');

   writeln('1) Площадь прямоугольника');

   writeln('2) Периметр прямоугольника');

   writeln('3) Диагональ прямоугольника');

   readln(c);

   if c = 1 then writeln('Площадь прямоугольника равна ', a*b:1:1)

   else if c = 2 then writeln('Периметр прямоугольника равна ', 2*(a+b):1:1)

   else if c = 3 then writeln('Диагональ прямоугольника равна ', sqrt(sqr(a)+sqr(b)):1:1)

   else writeln('Введёно некорректное значение.')

end.

Задача 3:

program HW3;

var a,i:integer;

begin

   a := 0;

   for i := 1 to 99 do

       begin

           if (i mod 2 ) <> 0 then a := a + i

       end;

   writeln('Cуммa ряда 1, 3, 5..99: ', a);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Даны три целых числа. Выбрать из них те, которые принадлежат отрезку [1, 3]. (Условный оператор) 2) Даны 2 стороны. Составить программу, которая по введенному значению 1, 2, 3 вычисляет: 1: Площадь прямоугольника 2: Периметр прямоугольника 3: Диагональ прямоугольника. (Множественный выбор) 3) Найти сумму ряда S=1+3+5+...+99. (Циклы)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Allahverdi_Мария475
struev2003260
Vyacheslavovich-Gubanov
АлексейГагиковна1774
За спам сразу бан , так что без этого
rodsher7740
kazanoop
Исмагилова_Саният
Баринова
Зияева57
far-yuliya128
Сергеевна-С.А.1549
Алёна Геннадьевна98
school24mir23
bal4shovser16
Iselickaya1890