№1
pers1 = 'китенок'
print(pers1)
pers2 = 'динозавр Митя'
print(pers2)
pers3 = 'Леонид Васильевич'
print(pers3)
act1 = 'плыл по морю'
print(act1)
act2 = 'рыбачил'
print(act2)
act3 = 'решал задачу'
print(act3)
def1 = 'в кузове грузовика'
print(def1)
def2 = 'в красных башмаках'
print(def2)
def3 = 'в пурпурном пиджаке'
print(def3)
print(pers2, act1, def3)
print(pers1, act2, def2)
print(pers3, act2, def1)
print(pers2, act3, def2)
№2
print('|-|--|---||||||||||||||')
№3
print(2, 3, 5, 7)
print(11, 13, 17, 19)
print(23, 29, 31, 37)
print(41, 43, 47)
№4
print('print("Привет, мир!")')
Поделитесь своими знаниями, ответьте на вопрос:
решить задачу на питон Спортсмен Василий участвовал в соревнованиях по хоккейболу и получил в личном зачете серебряную медаль. Известно, что участники, получившие одинаковое количество очков, награждаются одинаковыми наградами. Известно, что были разыграны золотые серебряные и бронзовые медали. В задаче не спрашиваются правила хоккейбола. Необходимо только определить сколько очков набрал Василий. Для решения данной задачи массив лучше не использовать. Входные данные На первой строке дано число N (2 ≤ N ≤ 1000) количество спортсменов, участвовавших в соревнованиях, на второй N целых чисел – результаты через пробел. Выходные данные Требуется вывести одно число – результат Василия Примеры входные данные 5 4 3 3 1 2 выходные данные 3 входные данные 8 1 2 5 3 5 6 6 5 выходные данные 5
Відповідь:
#include <stdio.h>
#include <iostream>
#include <cstdlib>
#include <time.h>
using namespace std;
void randarr(int *arr,int size){
for(int i = 0; i < size; i++){
arr[i] = rand() % 40 + 0;
}
}
void printarr(int *arr,int size){
for(int i = 0; i < size; i++){
printf("%d\t", arr[i]);
}
}
void sortminmax(int *arr,int size){
for(int i = 0; i < size - 1; ++i){
int small = i;
for (int j = i + 1; j < size; ++j){
if (arr[j] < arr[small]){
small = j;
}
}
swap(arr[i], arr[small]);
}
}
void sortmaxmin(int *arr,int size){
for(int i = 0; i < size - 1; ++i){
int big = i;
for (int j = i + 1; j < size; ++j){
if (arr[j] > arr[big]){
big = j;
}
}
swap(arr[i], arr[big]);
}
}
int main(){
srand(time(NULL));
setlocale(LC_ALL, "Rus");
int size;
printf("Введите размер массива: ");
scanf("%d" , &size);
int *arr = new int[size];
printf("Массив: ");
randarr(arr,size);
printarr(arr,size);
printf("\nСортируем массив по возрастанию от наименьшего до наибольшего...");
printf("\nРезультат: ");
sortminmax(arr,size);
printarr(arr,size);
printf("\nСортируем массив по убыванию от наибольшего до наименьшего...");
printf("\nРезультат: ");
sortmaxmin(arr,size);
printarr(arr,size);
delete[] arr;
return 0;
}