Nikolai710
?>

Информатика! ПИТОН СтрокиЯ очень туплюЗначение выраженияДана строка, состоящая из n цифр (т.е. однозначных чисел), между которыми стоит n−1 знак операции, каждый из которых может быть либо +, либо −. Вычислите значение данного выражения.Входные данныеНа вход подается строка, состоящая из цифр, а также символов + и −.Выходные данныеВыведите ответ на задачу.ПримерыВвод1+2-3Вывод0

Информатика

Ответы

Наталья_Владимир708

https://onlinegdb.com/S1IjQ7SUU --- Код на Python в песочнице

Если нужен сам код сразу - она ниже (про отступы не забудь, если будешь копировать прямо отсюда):

row = str(input("Enter your math expression: "))

a = []

res = 0

for i in range(len(row)):

   a.append(row[i:i+1])

#    print(a[i])  --  Если хочешь посмотреть на результаты

#                     посимвольного разделения строки

#                     (больше для себя комментарий делал)

for i in range(len(row)):

   if (a[i] == "-"):

       res = res - (int(a[i+1]))

   elif (a[i] == "+"):

       res = res + (int(a[i+1]))

   elif (i == 0):

       res = res + (int(a[i]))

print("Resul of your math expression: ",res)

Если что, результати с консоли вывода тоже прикрепил

Удачи там с Python-ом ))


Информатика! ПИТОН СтрокиЯ очень туплюЗначение выраженияДана строка, состоящая из n цифр (т.е. одноз
Rakitin

 Задача нелогичная, получается, что он должен обучиться 5 операциям (4 действия и числа), на все эо дано 3 месяца. 

1. Пусть за 1й мес он выучит числа - то есть 1 операцию.

2. За 2й мес он выучит + или -, то есть 1 операцию.

3. За 3й мес он выучит или -, или *, или : ЛИБО или +, или *, или : - то есть 1 операцию.

Всего за 3 месяца он может выучит 3 операции из желаемых 5 независимо от того, в какой последовательности он будет осваивать их.

ответ: не успеет, ему необходимо 5 месяцев либо увеличить количество операций, изучаемыз в месяц.

Как-то так я думаю

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ЧумичеваГеннадьевна1827

 Задача нелогичная, получается, что он должен обучиться 5 операциям (4 действия и числа), на все эо дано 3 месяца. 

1. Пусть за 1й мес он выучит числа - то есть 1 операцию.

2. За 2й мес он выучит + или -, то есть 1 операцию.

3. За 3й мес он выучит или -, или *, или : ЛИБО или +, или *, или : - то есть 1 операцию.

Всего за 3 месяца он может выучит 3 операции из желаемых 5 независимо от того, в какой последовательности он будет осваивать их.

ответ: не успеет, ему необходимо 5 месяцев либо увеличить количество операций, изучаемыз в месяц.

Как-то так я думаю

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Информатика! ПИТОН СтрокиЯ очень туплюЗначение выраженияДана строка, состоящая из n цифр (т.е. однозначных чисел), между которыми стоит n−1 знак операции, каждый из которых может быть либо +, либо −. Вычислите значение данного выражения.Входные данныеНа вход подается строка, состоящая из цифр, а также символов + и −.Выходные данныеВыведите ответ на задачу.ПримерыВвод1+2-3Вывод0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

korneevaa
turaev-1098
juliaWinter
elvini857
stasyan
ustinov434
yulyaderesh
tata-novik
сергей1246
alex6543213090
suhanowaswetlana
ebelskaia
asvavdeeva
matveevaev81
shkola8gbr