sbraginets
?>

Выполняя первую из них, Альфа увеличивает число на экране на 2, а выполняя вторую, умножает это число на b. Известно, что программа 12121 переводит число 3 в число 90. Определите значение b.

Информатика

Ответы

Kalashnikova

4 или -4,4

Обычно указывают целое

Объяснение:

((3+2)×b+2)×b+2=90

5b^2+2×b-88=0

b1=4

b2=-4,4

maksimforyou20

4

Объяснение:

1) 3+2=5 (команда 1)

2) 5*b (команда 2)

3) 5b+2 (команда 1)

4) (5b+2)*b (команда 2)

5) 5b*b+2b+2 (команда 1) =90

5b*b+2b-88=0

D=b*b-4*a*c=4-4*5*(-88) =4+1760=1764

√D=42

b1= (-2+42) /10=4

b2= (-2-42) /10=-4,4

По данному условию либо -4,4 либо 4 так как задача неполная; но по полному решению ответ будет 4

slastena69678
Const
    handsfree = false;

var
    a: array[1..100] of integer;
    i, n: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {изменение элементов}
    writeln('Вывод прямой:');
    for i := 1 to n do
        write(a[i], ' ');
    writeln();
    
        {изменение элементов}
    writeln('Вывод обратный:');
    for i := n downto 1 do
        write(a[i], ' ');
end.
Nadezhdachizhikova7968
Const
    handsfree = false;

var
    a: array[1..100] of integer;
    i, n: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {изменение элементов}
    writeln('Вывод прямой:');
    for i := 1 to n do
        write(a[i], ' ');
    writeln();
    
        {изменение элементов}
    writeln('Вывод обратный:');
    for i := n downto 1 do
        write(a[i], ' ');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Выполняя первую из них, Альфа увеличивает число на экране на 2, а выполняя вторую, умножает это число на b. Известно, что программа 12121 переводит число 3 в число 90. Определите значение b.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lovely138887
ruslan
Dom540703174
Милита1065
kuz-vlad21
Палкина-Дроздова
mirsanm26249
office426
heodbxbbshe
armsam76
nsn-2012
gennadevna
mir5552
bogdanovaoksa
aniramix