suhanowaswetlana
?>

СДЕЛАЙТЕ ПРОГРАММУ НА ПАСКАЛЕ 17. заданы целые числа: k, l, n, m. проверить, является ли k делителем всех чисел. 19. заданы числа a, b, c. напечатать эти числа в порядке убывания их абсолютных величин. И НОМЕР 21 ОН В ФОТО

Информатика

Ответы

Galinova2911

(см. объяснение)

Объяснение:

Задание №17:

//Привычный тебе код:

var k,l,n,m: integer;

begin

 write('Введите число k >> '); readln(k);

 write('Введите число l >> '); readln(l);

 write('Введите число n >> '); readln(n);

 write('Введите число m >> '); readln(m);

 if((l mod k = 0) and (n mod k = 0) and (m mod k = 0)) then writeln('Является!')

 else writeln('Не является!');

end.

//Альтернативное решение задачи нестандартным методом:

begin

 var k: integer := ReadInteger('Введите число k >>');

 var l: integer := ReadInteger('Введите число l >>');

 var n: integer := ReadInteger('Введите число n >>');

 var m: integer := ReadInteger('Введите число m >>');

 if((l mod k = 0) and (n mod k = 0) and (m mod k = 0)) then writeln('Является!')

 else writeln('Не является!');

end.

Задача №19:

//Привычное тебе решение:

var a,b,c: real;

procedure isBiggest(x,y,z: real);

begin

 if((x>y) and (y>z))

   then begin  

          writeln('ответ: ', x, ', ', y, ', ', z);

          exit;

        end;

end;

begin

 write('Введите число a >> '); readln(a);

 write('Введите число b >> '); readln(b);

 write('Введите число c >> '); readln(c);

 isBiggest(a,b,c); isBiggest(a,c,b);

 isBiggest(b,a,c); isBiggest(b,c,a);

 isBiggest(c,a,b); isBiggest(c,b,a);

end.

//Альтернативное решение задачи.

//Уникальность кода в том, что он работает при любом количестве данных чисел. Все зависит от ReadArrReal(n);

begin

 'Введите числа a,b,c через пробел:'.Println;

 var x: array of real := ReadArrReal(3);

 System.Array.Sort(x);

 System.Array.Reverse(x);

 x.Println;

end.

Задача №21:

//Привычное для тебя решение:

var x: real;

begin

 writeln('Введите число x >>'); readln(x);

 if(x<0) then writeln(4)

   else if(x>1) then writeln(x+7)

          else writeln(x*x+3*x+4);

end.

//Альтернативное решение:

//Используется тип double для большей точности

begin

 var x: double := ReadReal('Введите число x >>');

 if(x<0) then writeln(4)

   else if(x>1) then writeln(x+7)

     else writeln(x*x+3*x+4);

end.

dashanna04225

Файл размером 15 Кбайт передаётся через некоторое соединение за 60 секунд. Определите, за сколько секунд можно передать этот же файл через соединение, скорость которого на 2048 бит в секунду больше. В ответе укажите одно число — количество секунд. Единицы измерения писать не нужно.

Решение.

Размер переданного файла = время передачи · скорость передачи. Скорость передачи файла в первом случае 15360/60 = 256 байт/сек. Скорость передачи во втором случае на 2048 бит = 256 байт в секунду больше, чем в первом, следовательно, исходный файл можно передать за 15360 / 512 = 30.

Объяснение:

Sonyamaslo6

Объяснение:

непозиционных системах счисления вес цифры (т. е. тот вклад, который она вносит в значение числа) не зависит от ее позиции в записи числа. Так, в римской системе счисления в числе ХХХII (тридцать два) вес цифры Х в любой позиции равен просто десяти.

В позиционных системах счисления вес каждой цифры изменяется в зависимости от ее положения (позиции) в последовательности цифр, изображающих число. Например, в числе 757,7 первая семерка означает 7 сотен, вторая — 7 единиц, а третья — 7 десятых долей единицы.

Сама же запись числа 757,7 означает сокращенную запись выражения

700 + 50 + 7 + 0,7 = 7 . 102 + 5 . 101 + 7 . 100 + 7 . 10—1 = 757,7.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

СДЕЛАЙТЕ ПРОГРАММУ НА ПАСКАЛЕ 17. заданы целые числа: k, l, n, m. проверить, является ли k делителем всех чисел. 19. заданы числа a, b, c. напечатать эти числа в порядке убывания их абсолютных величин. И НОМЕР 21 ОН В ФОТО
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

петрАфанасьев
delta88
Олег2014
manager9
a-zotova
Николаевич1033
fab2004
Наталья Юрьевич1228
Олимов Протопопова
ElenaSkvortsova2
Sonyamaslo6
luxoutlet
rynaodal
Maionova
kol-nat26