Написать программу, которая рассчитывает время в пути на автомобиле со средней скоростью 90 км/ч из Москвы в Архангельск Расстояние Москва Архангельск по трассе составляет 1225 км.
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016 begin var n:=ReadInteger('n='); var a:=ArrRandom(n,-50,50); Writeln('Исходный массив'); a.Println; var se:=a.Where(x->x mod 3=0); if se.Count=0 then Writeln('В массиве нет элементов, кратных трем') else begin var b:=se.Max; var i:=0; while a[i]<>b do Inc(i); if i=n-1 then Writeln('Максимальный элемент - последний') else begin Writeln('Результирующий массив'); a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println end end end.
m 8 5 n 3 ясно, что основание искомой с/с > 10. Проверим и удостоверимся, что в 11c|c действия выполняются верно. 11 c|c M=6 n = 4 ответ: основание системы 11, m=6, n=4
2. m m 65 n +2 n 4 4 m
5 5 4 2 4 очевидно, что основание искомой с/с > 6. Проверим по действиям в 7 с/с, при сложении в столбик, при m=3 и n=1 и удостоверимся, что всё верно. ответ: осн. с\с = 7, m=3, n=1
Написать программу, которая рассчитывает время в пути на автомобиле со средней скоростью 90 км/ч из Москвы в Архангельск Расстояние Москва Архангельск по трассе составляет 1225 км.
begin
var n:=ReadInteger('n=');
var a:=ArrRandom(n,-50,50);
Writeln('Исходный массив'); a.Println;
var se:=a.Where(x->x mod 3=0);
if se.Count=0 then
Writeln('В массиве нет элементов, кратных трем')
else begin
var b:=se.Max;
var i:=0;
while a[i]<>b do Inc(i);
if i=n-1 then Writeln('Максимальный элемент - последний')
else begin
Writeln('Результирующий массив');
a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println
end
end
end.
Тестовое решение:
n= 15
Исходный массив
-24 -38 15 -33 -40 -18 21 34 20 49 -19 29 29 38 -41
Результирующий массив
-24 -38 15 -33 -40 -18 21 213 20 49 -19 29 29 38 -41