fomindmity1
?>

Вам дана программа, в которой создается массив и выводится на экран а также вводятся 2 числа: n и k - количество элементов и значение первого элемента массива. Дополните программу таким образом, чтобы массив заполнялся по следующему правилу: каждый следующий элемент на три больше предыдущего. #include using namespace std; int main() { int a[100], n, k; cin >> n >> k; // место для вашего фрагмента программы for (int i = 0; i < n; i++) { cout << a[i] << " "; } return 0; } Формат входных данных С клавиатуры вводится натуральное число n (n≤100) - количество элементов. На следующей строке вводится целое число - первый элемент массива. Все числа по модулю не превосходят 10000. Формат выходных данных В качестве ответа выведите массив Примечания В задачу требуется отправлять только указанный фрагмент кода. P.s язык программирования С++

Информатика

Ответы

olegmgu1

Объяснение:

a[0]=k;

for (int i = 1; i < n; i++) {

a[i]=a[i-1]+3;

}

nekataniyoleg

   a[0] = k;

   for (int i = 1; i < n; i++)

       a[i] = a[i-1] + 3;

zibuxin6

ответ:

объяснение:

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

const n=23; m=40; //n-ряды, m-места

var

  a: array[1..n,1..m] of integer; //зрительный зал

  i,j,k: integer;

begin

  randomize;

  writeln('зрительный зал: ');

  write('м/р');

  for i: =1 to m do write(i: 3);

  writeln;

  for i: =1 to n do begin

    write(i: 3);

    for j: =1 to m do begin

      a[i,j]: =ord(random(10)> 0); write(a[i,j]: 3); //read(a[i,j]); я ввожу гадалкой, т.к. руками вбивать 920 цифирь не входит в мое понятие героизма

    end;

    writeln;

  end;

  repeat

    write('в каком ряду смотреть свободные места? ');

    readln(i);

  until (i> 0) and (i

  k: =0;

  for j: =1 to m do k: =k+ord(a[i,j]=0); //cчитаем свободные места

  write('в ряду ',i);

  if k> 0 then writeln(' есть свободные места в количестве ',k,' шт.') else

  writeln(' свободных мест нет');

end.

tarigor

ответ:

uses crt;

var a: array[1..20,1..20] of real;

    n,m,i,j: integer;

    s: real;

begin

    clrscr; randomize;

    write('введите кол-во строк: '); readln(n);

    write('введите кол-во столбцов: '); readln(m);

    for i: =1 to n do

    begin

      for j: =1 to m do

      begin

        a[i,j]: =random(100)/10;

        write(a[i,j]: 4: 1);

      end;

      writeln;

    end;

    for i: =1 to n do

    begin

      s: =0;

      for j: =1 to m do

      s: =s+a[i,j];

      writeln('сумма ',i,'-ой строки: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      for i: =1 to n do

      s: =s+a[i,j];

      writeln('сумма ',j,'-ого столбца: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      if j mod 2 = 0 then  

      begin

        for i: =1 to n do

        s: =s+a[i,j];

        writeln('среднее арифметическое ',j,'-ого столбца: ',s/m: 0: 1);

      end;

    end;

    readln;

end.

объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вам дана программа, в которой создается массив и выводится на экран а также вводятся 2 числа: n и k - количество элементов и значение первого элемента массива. Дополните программу таким образом, чтобы массив заполнялся по следующему правилу: каждый следующий элемент на три больше предыдущего. #include using namespace std; int main() { int a[100], n, k; cin >> n >> k; // место для вашего фрагмента программы for (int i = 0; i < n; i++) { cout << a[i] << " "; } return 0; } Формат входных данных С клавиатуры вводится натуральное число n (n≤100) - количество элементов. На следующей строке вводится целое число - первый элемент массива. Все числа по модулю не превосходят 10000. Формат выходных данных В качестве ответа выведите массив Примечания В задачу требуется отправлять только указанный фрагмент кода. P.s язык программирования С++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zverevahelen
egoryandiana3727283
yliana
igschuschkov6211
Назаров588
dream2366
Александрович Владимирович
milkiev
abroskin2002
horina12
Oksana-Kirakosyan1301
bandurinei
zrs-546
kris5009646
AlekseiMardanova