PivovarovaIlina1437
?>

Написать программу на языке PASCAL, реализующую алгоритм решения следующих задач (одной на выбор): 1. Вывод суммы натуральных чисел в заданном диапазоне Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы соответственно Выходные данные: Число – сумма всех натуральных чисел от N1 до N2 включительно. 2. Вывод произведения натуральных чисел в заданном диапазоне Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы соответственно Выходные данные: Число –произведение всех натуральных чисел от N1 до N2 включительно.

Информатика

Ответы

nikv568734

Задача 1

var

 i, sum, n1, n2: integer;

begin

 readln(n1, n2);

 for i := n1 to n2 do  

   sum := sum + i;

 writeln(sum);

end.

Задача 2

var

 i, n1, n2: integer;

 p: BigInteger;

begin

 p := 1;

 readln(n1, n2);

 for i := n1 to n2 do  

   p := p * i;

 writeln(p);

end.

vintazhvintazh90

const

   handsfree = false;

   nmax = 10;

   random_min = -50;

   random_max = 50;

var

   a: array[0..nmax] of real;

   i, n: integer;

   sum, x: real;

begin

   {ввод массива}

   n := nmax;

   if handsfree then begin

       for i := 0 to n do

       begin

           a[i] := random(random_max - random_min) + random_min;

           write(a[i], ' ');

       end

   end

   else begin

       for i := 0 to n do

           readln(a[i]);

   end;

   writeln();

   

   {подсчет суммы}

   write('x = ');

   readln(x);

   

   sum := a[n];

   for i := n - 1 downto 0 do

       sum := sum * x + a[i];

   writeln('S = ', sqrt(sum));

end.

VladimirovnaBugrova

Текстовый редактор предназначен именно для редактирования текста, четкого выставления знаков, например написания кода программ, просмотра файлов данных и т.п. Например заменить русской "у" латинское "y" будет считаться ошибкой

Текстовый процессор предназначен для создания и редактирования документов которые не предназначены для чтенья компьютером, но человеком. Когда внешний вид важнее реально содержащихся знаков ( допустимо заменить русской "у" латинское "y"). Так же там есть форматирование (шрифт, размер..), вставка обьектов типа рисунков и прочее внешнее оформление

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке PASCAL, реализующую алгоритм решения следующих задач (одной на выбор): 1. Вывод суммы натуральных чисел в заданном диапазоне Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы соответственно Выходные данные: Число – сумма всех натуральных чисел от N1 до N2 включительно. 2. Вывод произведения натуральных чисел в заданном диапазоне Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы соответственно Выходные данные: Число –произведение всех натуральных чисел от N1 до N2 включительно.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Smolkovaya
natkuv7
hello
Olesya-elena1525
departed744
araqsyabadalyan1988
Mexx9050
alexeylipatov
zipylin
konstantinslivkov
Александрович175
afilippov3321
​
vlsvergun59
Попов1946
sv-rud
▲