Поделитесь своими знаниями, ответьте на вопрос:
Пользователь выводит с клавиатуры числа P - первый член прогрессии, R -разность прогрессии и число N. Написать программу которая выводит на экран суммы членов арифметической прогрессии не привышающую N
Program abc;
var P,R,N,D,A,C: integer;
var B:real;
begin
write('Введите число P(Первый член прогрессии) - ');
Read(P);
write('Введите число R(Разность прогрессии) - ');
Read(R);
write('Введите число N(Число которое не может привышаться) - ');
Read(N);
D:=2*P;
A:=D+R*(N-1);
B:=A/2*N;
If (B>N) then writeln('ответ превышает число N')
else Writeln('Сумма членов арифметической прогрессии:' B);
end.
Быстро прочекал что такое арифметическая прогрессия и попытался написать код. Не суди строго если что-то не так)