Николаевич1033
?>

язык прогр. питон Дана строка, найти слово, которое чаще встречается в тексте, перевернуть его и вставить в то, же место ​

Информатика

Ответы

kisa-luba

--- Python 3.8.3 x64 ---

import collections  

import re

import string

def ClearString(RawString):

   return re.sub(r' +', ' ', re.sub(rf'[{string.punctuation}]|\n', '', RawString))

def main():

   RawString = input()

   OrigString = RawString

   MostCommonWord = collections.Counter(ClearString(RawString).split(' ')).most_common()[0][0]

   RedactedString = re.sub(rf'{MostCommonWord}', MostCommonWord[::-1], OrigString)

   print(RedactedString)

   

if __name__ == "__main__":

   main()

Объяснение:

thedoomsdatdcs36
//PascalABC.Net 3.0, сборка 1064
type
  IntArray = array of integer;

var
  rows, cols: integer;
  M: array of IntArray;

begin
  Write('Количество строк и столбцов матрицы: '); Read(rows, cols);
  var Avg: array of double := new double[cols];
  M := new IntArray[rows];
  SetLength(Avg, cols);
  for var i := 0 to rows - 1 do
  begin
    M[i] := ArrRandom(cols, -25, 25);
    M[i].Println(#9)
  end;
  for var j := 0 to cols - 1 do
    Avg[j] := Range(0, rows - 1).Select(x -> M[x, j]).Average;
  Writeln('Наименьшее среднее по столбцам равно ', Avg.Min)
end.

Тестовое решение:
Количество строк и столбцов матрицы: 5 8
-22    -8    12    7    3    -18    8    22
2    -16    17    -13    -10    0    -19    2
20    -21    -6    13    2    -20    25    24
-7    -3    -2    -10    -2    8    18    23
4    -21    -8    8    23    -12    -13    -5
Наименьшее среднее по столбцам равно -13.8
kriapex
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

язык прогр. питон Дана строка, найти слово, которое чаще встречается в тексте, перевернуть его и вставить в то, же место ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Svetlana1877
dimiff5
proplenkusale88
tarkhanovilya
TrubnikovKlimenok926
gudachaa1480
Vladimirovna Viktorovna
Корнеплодович1930
bmargarita
Buninilya
rodsher7740
Владимир
osnovnoisklad3551
mursvita943
goryavinan