xsmall1
?>

(Python) Бандиты Гарри и Ларри отдыхали на природе. Решив пострелять, они выставили на бревно несколько банок из-под кока-колы (не больше 10 Гарри начал банки по порядку, начиная с самой левой, Ларри — с самой правой. В какой-то момент получилось так, что они одновременно одну и ту же последнюю банку. Гарри возмутился и сказал, что Ларри должен ему кучу денег за то, что тот лишил его удовольствия несколько банок. В ответ Ларри сказал, что Гарри должен ему еще больше денег по тем же причинам. Они стали спорить кто кому сколько должен, но никто из них не помнил сколько банок было в начале, а искать банки по всей округе было неохота. Каждый из них помнил только, сколько банок он сам. Определите по этим данным, сколько банок не Гарри и сколько банок не Ларри. Входные данные: Пользователь вводит 2 числа (каждое меньше 10) — количество банок Гарри и Ларри соответственно. Выходные данные: Выведите 2 числа — количество банок, не Гарри и Ларри соответственно.

Информатика

Ответы

Николаев

pascal

Объяснение:

var

 i, j ,k: integer;

 l, lnew: string;

 a: array of integer;

begin

 Write('Введите число >> ');

 ReadLn(l);

 SetLength(a ,length(l));

 for i := 0 to length(l) - 1 do

   a[i] := strtoint(l[i + 1]);    

 for i := 0 to length(l) - 2 do

     for j := i + 1 to length(l) - 1 do

       if a[i] > a[j] then

       begin

         k := a[i];

         a[i] := a[j];

         a[j] := k;

       end;

 

  for i := 0 to length(l) - 1 do

   lnew := lnew + inttostr(a[i]);

 WriteLn('Новое число равно ', lnew);

end.

artmasterstyle

pascal

Объяснение:

var

 i, j ,k: integer;

 l, lnew: string;

 a: array of integer;

begin

 Write('Введите число >> ');

 ReadLn(l);

 SetLength(a ,length(l));

 for i := 0 to length(l) - 1 do

   a[i] := strtoint(l[i + 1]);    

 for i := 0 to length(l) - 2 do

     for j := i + 1 to length(l) - 1 do

       if a[i] > a[j] then

       begin

         k := a[i];

         a[i] := a[j];

         a[j] := k;

       end;

 

  for i := 0 to length(l) - 1 do

   lnew := lnew + inttostr(a[i]);

 WriteLn('Новое число равно ', lnew);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

(Python) Бандиты Гарри и Ларри отдыхали на природе. Решив пострелять, они выставили на бревно несколько банок из-под кока-колы (не больше 10 Гарри начал банки по порядку, начиная с самой левой, Ларри — с самой правой. В какой-то момент получилось так, что они одновременно одну и ту же последнюю банку. Гарри возмутился и сказал, что Ларри должен ему кучу денег за то, что тот лишил его удовольствия несколько банок. В ответ Ларри сказал, что Гарри должен ему еще больше денег по тем же причинам. Они стали спорить кто кому сколько должен, но никто из них не помнил сколько банок было в начале, а искать банки по всей округе было неохота. Каждый из них помнил только, сколько банок он сам. Определите по этим данным, сколько банок не Гарри и сколько банок не Ларри. Входные данные: Пользователь вводит 2 числа (каждое меньше 10) — количество банок Гарри и Ларри соответственно. Выходные данные: Выведите 2 числа — количество банок, не Гарри и Ларри соответственно.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zelinskaya-Andrei
aromastil88
zibuxin6
Lavka2017
kronid12
lechic3
Belik-elena20111
КириллЕгорова1906
Иванов
SEMENOV25352
ipKAV85
Mamikin
Olga Arutyunyan
snab54