braigon974
?>

решить две задачи по информатике 10 класс1. Написать программу нахождения среднего арифметического любых 5 чисел. 2. Учение в первый день выучил 5 английских слов. В каждый последующий день он выучивал на 2 слова больше, чем в предыдущий. Сколько английский слов выучит ученик за 10 дней. План решения:постановка задачи, формализация, блок-схема, программирование

Информатика

Ответы

mikek0906

уточнять на каком языке программирования нужно написать задачки. Я же напишу на С++. Алгоритм везде будет один и тот же.

1 задача

int x1 = 0;

int x2 = 0;

int x3 = 0;

int x4 = 0;

int x5 = 0;

cin >> x1;

cin >> x2;

cin >> x3;

cin >> x4;

cin >> x5;

double sr = 0.0;

sr = (x1+x2+x3+x4+x5)/5;

Или же можно сделать по проще

int x = 0;

int sum = 0;

double sr = 0.0;

for(int i = 0; i<5; i++){

cin >> x;

sum = sum +x;

}

sr = sum/5;

2 Задача

int number = 5;

for(int i = 2; i<20; i=i+2){

number = number + i;

}

vet30
Const n=30;
var a: array[1..n] of integer;
    tek,k,i,j: integer;
begin
{ заполнение массива и вывод на экран } 
 for j:=1 to n do 
 begin
     a[j]:=Random(20);
     write(a[j],' ');   
     if (j mod 10 = 0) then writeln; 
 end;
 writeln;
{ цикл обработки массива } 
 for i:=1 to n do 
 begin
    tek:=a[i];
    k:=i;
{ просмотр на повторные }
    for j:=i+1 to n do 
    begin
      if (a[j]=tek) then
      begin
        a[k]:=0;
        k:=j;
      end;
    end;
  end; { конец обработки массива }
{ вывод итогового массива на экран }
  for i:=1 to n do
  begin 
    write(a[i],' ');
    if (i mod 10 = 0) then writeln;
  end;
end.
ainred
відеокарта-потрібна для виводу зображення на монітор
материнська плата-потрібна для поєднування усіх комплектуючих
оперативна пам'ять - потрібна для зберігання коду та даних програми під час їхнього виконування
блок живлення - потрібен для живлення усіх перерахованих тут комплектуючих
звукова карта потрібна для виводу звуку
процесор обробка даних по заданій програмі шляхом виконання арифметичних і логічних операцій. програмне керування роботою пристроїв комп'ютера.
накопичувач SSD HDD 
ssd- комп'ютерний запам'ятовувальний пристрій на основі мікросхем пам'яті та контролера керування ними, що не містить рухомих механічних частин.
hdd- магнітний диск, основа якого виконана з твердого матеріалу. У більшості виконує функцію енергозбережливого носія інформації

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить две задачи по информатике 10 класс1. Написать программу нахождения среднего арифметического любых 5 чисел. 2. Учение в первый день выучил 5 английских слов. В каждый последующий день он выучивал на 2 слова больше, чем в предыдущий. Сколько английский слов выучит ученик за 10 дней. План решения:постановка задачи, формализация, блок-схема, программирование
Ваше имя (никнейм)*
Email*
Комментарий*