natkoff5
?>

Составьте программу, которая будет сначала спрашивать ваше имя, а когда вы его введёте, с восклицанием приветствовать вас. Последовательность следующая: Программа: Как тебя зовут? Вы: Коля Программа: Привет, Коля! Обратите внимание на то, чтобы при выводе приветствия были правильно расставлены пробелы (после запятой - перед именем - есть, а перед восклицательным знаком нет Каждая реплика должна выводиться/вводиться с новой строки.

Информатика

Ответы

Александрович Владимирович

print ("Как Вас зовут?")

x= input ()

print ("Приветствую вас,"+x+"!")

Алексей Кирилл1094
Летающий автобус)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли.  Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a  и написать программу:

var a,b:integer;
begin
  repeat
    writeln('Введите количество непроданных билетов (a,b)');
    readln(a,b);
  until (a<=120) and (b<=40)and (a>=0) and (b>=0);
  writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.

 
innaterenina
Летающий автобус)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли.  Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a  и написать программу:

var a,b:integer;
begin
  repeat
    writeln('Введите количество непроданных билетов (a,b)');
    readln(a,b);
  until (a<=120) and (b<=40)and (a>=0) and (b>=0);
  writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая будет сначала спрашивать ваше имя, а когда вы его введёте, с восклицанием приветствовать вас. Последовательность следующая: Программа: Как тебя зовут? Вы: Коля Программа: Привет, Коля! Обратите внимание на то, чтобы при выводе приветствия были правильно расставлены пробелы (после запятой - перед именем - есть, а перед восклицательным знаком нет Каждая реплика должна выводиться/вводиться с новой строки.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

blagorodovaanna375
zuzman601
Татьяна902
partners
Сергеевич1907
karpachevamarina
Оксана
arturnanda803
тахирович_Игорь581
andy74rus36
lanabogd
eduard495
happych551
MikhailovnaAnastasiya
АлександровнаВладимирович1424