Олегович Паутова
?>

Питон. Напишите программу которая заменяет в символьной строке все точки на нули и все буквы х на единицы. Например, из строки '..XX..X.' должна получиться строка '00110010’.

Информатика

Ответы

ooottdi

const N=5;

var i,j,max,sum,i1,j1:integer;

   a:array [1..N,1..N] of integer;

   st:boolean;

begin

 sum:=0; max:=0; i1:=0; j1:=0;

 st:=false;

 randomize;

 for i:=1 to n do  

   begin

     for j:=1 to n do

       begin

         a[i,j]:=random(31)-10;

         write(a[i,j]:4);

         if st = false then

           begin

             max:=a[i,j];

             st:=true;

           end

             else

               if a[i,j]>max then

                 max:=a[i,j];

          if a[i,j]>0 then

             begin

               i1:=i;

               j1:=j;

             end;

       end;

     writeln;

   end;

 writeln;

 for i:=1 to i1-1 do

   for j:=1 to n do

     sum:=sum+a[i,j];

 for j:=1 to j1-1 do

   sum:=sum+a[i+1,j];

 writeln('MAX: ',max);

 writeln('SUM: ',sum)

 

end.

Объяснение:

marketing6

В данной программе используется цикл с известным числом повторений

Объяснение:

Вот код этой программы:

uses DrawMan; //подключаем модуль с чертежником  

var   i: integer; //объявляем переменную-счетчик для цикла

begin

 Task('c1'); //вызываем задание

 ToPoint(1, 3); //перемещаемся к точке с координатами (1, 3)

 for i := 1 to 18 do //запускаем цикл

   begin

     PenDown; //опускаем перо

     OnVector(0, -1); //перемещаемся на вектор (0, -1)

     OnVector(1, 1); //перемещаемся на вектор (1, 1)

   end;

 PenUp; //поднимаем перо

 ToPoint(0, 0); //перемещаемся к точке с координатами (0, 0)

end.

Циклы в "Паскале" - это алгоритм действий который выполняется определенное количество раз. Здесь используется цикл "for", для использования которого необходимо указать число итераций цикла.

Переменная i изменяется от 1 до 18, => вложенный в цикл код выполнится (18-1)+1 = 18 раз

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Питон. Напишите программу которая заменяет в символьной строке все точки на нули и все буквы х на единицы. Например, из строки '..XX..X.' должна получиться строка '00110010’.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

SVETLANAluiza1534
MaratФам
alisabutusova
zmlavra
Olgax732
Ruslan Zarekovkin
Александровна1973
janepustu
rimmaskis
Наталья
seleznev1980
Александрович
pavlino-mkr
okasnab
taanaami75