cherkashenko87543
?>

Найдите ошибки в операторах на языке Pascal.При записи условий на первом месте записывайте переменную.Program vetv2;Var x, y:real;BeginWriteln('Значение выражения');Write('Введите x, y');Readln(x, y);if 1then x:=x+1; y:=0;Else x:=0; y:=y+1;Writeln(x);Writeln (y);End.

Информатика

Ответы

Bmashutav16

if 1then x:=x+1; y:=0;

Else x:=0; y:=y+1;

// 1. не задано условие между if-then, должно быть: «if (условие) then»

// 2. перед else не должно быть знака «;» Можно написать так: «begin  x:=x+1; y:=0;  end else»

apro3444595
Т.к. язык программирования не указан, сделаю на свой вкус, т.е. C++. При копировании кода из IDE на сайт автоматически удаляется перенос строки. Будет прикреплен скриншот того, как должен выглядеть код

#include <stdlib.h>#include <stdio.h>#include <locale>
void main(){ setlocale(LC_ALL, "RUSSIAN"); int i, n, an; an = 0; printf("\n Введите n ->"); scanf_s("%d", &n); for (i = 1; i <= n; i++) an = an+i; printf("\n Сумма первых n натуральных чисел равна: %d", an); an = 0; for (i = 1; i <= n; i++) an = an + i*i; printf("\n Сумма квадратов первых n натуральных чисел равна: %d", an); an = 0; for (i = 1; i <= n; i++) if (i % 2 == 0)an = an + i; printf("\n Сумма всех четных чисел в диапозоне от 1 до n: %d", an); an = 0; for (i = 10; i <= 99; i++) an = an + i; printf("\n Сумма всех двухзначных чисел равна: %d \n", an); system("pause");}

Напишите программу,которая вычисляет сумму : а)первых n натуральных чисел; б)квадратов первых n нату
alfaduk24908
Текстовый алгоритм

Есть снег для лепки снеговика?

Нет - выполнение невозможно.

Есть, то: 

слепить три разновеликих шара;

установить шары друг на друга в порядке убывания;

сверху установить ведро дном вверх;

в центр верхнего шара установить морковь, над ней два уголька-глаза;

по бокам среднего шара вставить веточки-ручки.

Фигуры блок-схемы

Последовательность фигур может меняться в зависимости от требуемых условий и действий:

овал - обозначает начало блок-схемы и содержит само слово "начало" - ограничивающий символ;

параллелограмм - символ ввода-вывода данных;

прямоугольник обозначает действие - символ выполнения операции;

ромб  - фигура, содержащая условие, после которой происходит ветвление алгоритма - символ принятия решения;

круг используется при разрыве записи блок-схемы;

прямоугольник с удвоенными боковыми сторонами обозначает применение подпрограммы - символ повторяемости процесса;

заканчивается запись блок-схемы всегда овалом, который содержит слово "конец".

Порядок выполнения действий указывается линиями.

Блок-схема создания снеговика

Алгоритм создан при идеальных условиях:

если снег есть, то возможно скатать шары для снеговика;

в наличии есть ведро-шапка, морковь-нос, угольки и подходящие веточки;

никто не разрушает созданные фигуры. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найдите ошибки в операторах на языке Pascal.При записи условий на первом месте записывайте переменную.Program vetv2;Var x, y:real;BeginWriteln('Значение выражения');Write('Введите x, y');Readln(x, y);if 1then x:=x+1; y:=0;Else x:=0; y:=y+1;Writeln(x);Writeln (y);End.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mv7095
borisova-valeriya
gorovoy-dv4088
barekyan096140
Станислав Валерий1696
evamining
macmakka
lestnica
Кириллов57
lighturist
Роман1406
annasv8
aeykin
Shevtsov1818
zotovinbox468