Динков
?>

написать программу которая решает примеры на языке паскаля 1) 2в степени -x-cos x+ sin(2xy) 2) 2ctg(3x)-1/12*x в 2 степени +7x - 5

Информатика

Ответы

sharaeva-is
//Pascal ABC.NET v3.1 сборка 1172

Var
 ma:array of array of integer;
 i,j,n,r:integer;
begin
 readln(n);
 setlength(ma,n+1);
 for i:=1 to n do
 setlength(ma[i],n+1);
 writeln('Matrix:');
 for i:=1 to n do
 begin
  writeln;
  for j:=1 to n do
   begin
    ma[i,j]:=random(n);
    write(ma[i,j]:4);
   end;
 end;
 for i:=1 to n do
  for j:=i+1 to n do
  r:=r+ma[i,j];
 r:=r div 3;
 writeln;
 if odd(r) then writeln('Да') else writeln('Нет');
end.

Пример ввода:
4
Пример вывода:
Matrix:

   0   1   3   3
   3   0   0   3
   2   3   0   2
   3   0   2   3
Нет
petria742
//Pascal ABC.NET v3.1 сборка 1172

Var
 ma:array of array of integer;
 i,j,n,r:integer;
begin
 readln(n);
 setlength(ma,n+1);
 for i:=1 to n do
 setlength(ma[i],n+1);
 writeln('Matrix:');
 for i:=1 to n do
 begin
  writeln;
  for j:=1 to n do
   begin
    ma[i,j]:=random(n);
    write(ma[i,j]:4);
   end;
 end;
 for i:=1 to n do
  for j:=i+1 to n do
  r:=r+ma[i,j];
 r:=r div 3;
 writeln;
 if odd(r) then writeln('Да') else writeln('Нет');
end.

Пример ввода:
4
Пример вывода:
Matrix:

   0   1   3   3
   3   0   0   3
   2   3   0   2
   3   0   2   3
Нет

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу которая решает примеры на языке паскаля 1) 2в степени -x-cos x+ sin(2xy) 2) 2ctg(3x)-1/12*x в 2 степени +7x - 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

anitanemtsewa
vikka30
Savva1779
mulyugina365
milenaochirova01017424
asyaurkova
Рудаков Бахтовар
ВалерийАндреевна1788
ВалерийАндреевна1788
volchek01112240
slspam
mb9037479491
Юлия1689
airlineskozlova69
vypolga1347