Voronin-Albertovich
?>

Python, задачаСегодня утром жюри решило добавить в вариант еще одну задачу. Очень Легкую Задачу. ответственный секретарь Оргкомитета напечатал ее условие в одном экземпляре, и теперь ему до начала олимпиады надо напечатать еще N копий.В его распоряжении два ксерокса. Первый копирует лист за x секунд, а второй - за y. Можно использовать один ксерокс, а можно два (и даже одновременно, так как копировать можно не только с оригинала, но и с копии ему выяснить какое минимальное время ему понадобится.Формат вводаВводятся три числа: N, x, y.Формат выводаВыведите одно число - минимальное количество секунд, которое нужно на создание N копий.ПримерыВвод 4 1 1Вывод 3 Ввод 5 1 2Вывод 4

Информатика

Ответы

d43irina

N, x, y = map(int, input().split())

x_time, y_time = x, y

time = 0

if x > y:

   time += y

else:

   time += x

N -= 1

while N > 0:

   if x_time == y_time:

       N -= 2

       time += x

       y_time, x_time = y, x

   elif x < y:

       if x_time < y:

           x_time += x

           N -= 1

           time += x

   else:

       if y_time < x:

           y_time += y

           N -= 1

           time += y

print(time)

igor51766771

1)      видим, что в последней строке выводятся на экран переменные a и b, поэтому сначала нужно определить, что они обозначают в программе

2)      перед началом цикла переменные a и  b обнуляются

3)      на каждом шаге цикла при выполнении некоторого условия переменная a увеличивается на 1, а b увеличивается на x mod 10, то есть, на остаток от деления x на 10 – это последняя цифра десятичной записи числа x  

4)      в конце каждого шага цикла операция x:=x div 10 отсекает последнюю цифру в десятичной записи числа

5)      цикл заканчивается, когда перестаёт выполняться условие x > 0, то есть, когда все цифры исходного числа отброшены

6)      таким образом, делаем вывод: после завершения цикла в переменной a находится количество цифр в десятичной записи числа, а в переменной b – их сумма

7)      если было выведено 2 и 12, то в числе 2 цифры, и их сумма равна 12; таким образом, нам нужно найти все двузначные числа, в котором сумма значений цифр равна 12

8)      число 12 может быть разложено на два слагаемых, меньших 10, как

12 = 3 + 9 = 4 + 8 = 5 + 7 = 6 + 6 = 7 + 5 = 8 + 4 = 9 + 3,

нам подходят числа 39, 48, 57, 66, 75, 84 и 93

info292
program task31153145; const  N = 10; var  arr: array[1..N] of integer;  S, indexOfFifty: integer;  haveFifty: boolean; begin  haveFifty := false;  for var i := 1 to N do    begin      arr[i] := Random(100);      if (arr[i] > 10) and (arr[i] < 30) then        S := S + arr[i];          if arr[i] = 50 then            begin              indexOfFifty := i;              haveFifty := true;            end;    end;  if haveFifty = true then    Writeln('В МАССИВЕ ЕСТЬ ЧИСЛО 50, ЕГО ИНДЕКС = ', indexOfFifty)  else    Writeln('В МАССИВЕ НЕТ ЧИСЛА 50');  Writeln('S = ', S); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python, задачаСегодня утром жюри решило добавить в вариант еще одну задачу. Очень Легкую Задачу. ответственный секретарь Оргкомитета напечатал ее условие в одном экземпляре, и теперь ему до начала олимпиады надо напечатать еще N копий.В его распоряжении два ксерокса. Первый копирует лист за x секунд, а второй - за y. Можно использовать один ксерокс, а можно два (и даже одновременно, так как копировать можно не только с оригинала, но и с копии ему выяснить какое минимальное время ему понадобится.Формат вводаВводятся три числа: N, x, y.Формат выводаВыведите одно число - минимальное количество секунд, которое нужно на создание N копий.ПримерыВвод 4 1 1Вывод 3 Ввод 5 1 2Вывод 4
Ваше имя (никнейм)*
Email*
Комментарий*