Fedorovna
?>

(Python) Напишите программу, которая спрашивает день рождения пользователя в формате ДД/ММ/ и выводит сообщение: Вы родились в году, Д МММ. Вместо выведите год, Д - день без ведущего нуля, МММ - название месяца в родительном падеже. Например, если пользователь ввёл 02/12/1985, то вывод будет: Вы родились в 1985 году, 2 декабря. Указания: Используйте форматирование дат для чтения даты и вывода года и дня. Напишите функцию, которая по номеру месяца вернёт правильное название месяца и используйте её для вывода месяца.

Информатика

Ответы

palmhold578

Ро́бот (чеш. robot, от robota — «подневольный труд») — автоматическое устройство, предназначенное для осуществления различного рода механических операций, которое действует по заранее заложенной программе.

Робот-андроид ASIMO, производство Honda

Робот обычно получает информацию о состоянии окружающего пространства посредством датчиков (технических аналогов органов чувств живых организмов). Робот может самостоятельно осуществлять производственные и иные операции, частично или полностью заменяя труд человека[1][2]. При этом робот может как иметь связь с оператором, получая от него команды (ручное управление), так и действовать автономно, в соответствии с заложенной программой (автоматическое управление).

Назначения роботов могут быть самыми разнообразными, от увеселительных и прикладных и до сугубо производственных. Внешний вид роботов разнообразен по форме и содержанию, может быть каким угодно, хотя нередко в конструкциях узлов заимствуют элементы анатомии различных живых существ, подходящие для выполняемой задачи.

В информационных технологиях «роботами» также называют некоторые автономно действующие программы, например, боты или поисковые роботы.

ajsklan

код на C++:

#include <iostream>

#include <math.h>

using namespace std;

int main(int argc, char** args)

{

  int k;

  do {

      cin >> k;

  } while (k < 1 || k > int(pow(10, 8)));

  long long int result = 0;

  for (int i = 0, j = 0; j < k; i += 10, j++)  

  {

      result = long long int(pow(5 + i, 2));

  };

  cout << result << endl;

  system("pause");

  return 0;

}

Объяснение:  

В этом задании легко найти закономерность. Если число оканчивается на 25, то это *5 в квадрате (5, 15, 25, 35 и тд.). Используем в цикле i как увеличение числа 5 на 10, а вторую переменную j - как подсчет номера счастливого числа.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

(Python) Напишите программу, которая спрашивает день рождения пользователя в формате ДД/ММ/ и выводит сообщение: Вы родились в году, Д МММ. Вместо выведите год, Д - день без ведущего нуля, МММ - название месяца в родительном падеже. Например, если пользователь ввёл 02/12/1985, то вывод будет: Вы родились в 1985 году, 2 декабря. Указания: Используйте форматирование дат для чтения даты и вывода года и дня. Напишите функцию, которая по номеру месяца вернёт правильное название месяца и используйте её для вывода месяца.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vorota-grupp
Диана-Николаевна377
blagorodovaanna375
Semenova
mir5552
buslavgroupe
burylin9
andreu420082132
sergeykvik13
Yurevna
Tatyana_Minullina
peshnoshamon
djikia88
alekseev13602
Salnikov1730