dimiff5
?>

ПАСКАЛЬ Дан одномерный массив A[10]. Элементы массива – это случайные числа большие 0. Написать программу, которая будет находить произведение элементов массива, лежащих в интервале [20, 70].

Информатика

Ответы

zubov-073620

var i,s: integer;

begin

s:=1;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random(100);

 write(A[i],' ');

 if (A[i]>=20) and (A[i]<=70) then

 s:=s*A[i];

 end;

writeln();

writeln('Произведение элементов массива: ',s);

end.

Smirnovav1982422
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
const
  n=5;
type
  Matrix=array[1..n,1..n] of integer;

procedure DummySchool(var a:Matrix);
begin
  Writeln('Ввод элементов матрицы');
  for var i:=1 to n do begin
    Write(n,' элементов строки ',i,': ');
    for var j:=1 to n do Read(a[i,j]);
    end;
  Writeln('Сформирована матрица ',n,'x',n);
  for var i:=1 to n do begin
    for var j:=1 to n do Write(a[i,j]:5);
    Writeln
    end
end;

begin
  var B:Matrix;
  DummySchool(B);
  var sn:=0;
  var sp:=0;
  for var i:=1 to n do
    for var j:=1 to n do
      if B[i,j]<0 then sn+=B[i,j]
      else
        if B[i,j]>0 then sp+=B[i,j];
  Writeln('Сумма отрицательных ',sn);
  Writeln('Сумма положительных ',sp)
end.

Тестовое решение:
Ввод элементов матрицы
5 элементов строки 1: 6 23 -5 13 9
5 элементов строки 2: 42 0 -38 16 37
5 элементов строки 3: -5 -18 3 11 8
5 элементов строки 4: 9 13 -11 0 3
5 элементов строки 5: 19 -17 0 15 5
Сформирована матрица 5x5
    6   23   -5   13    9
   42    0  -38   16   37
   -5  -18    3   11    8
    9   13  -11    0    3
   19  -17    0   15    5
Сумма отрицательных -94
Сумма положительных 232
astenSA
После того как мы узнали, что такое уравнение, и научились решать самые простые из них, в которых находили неизвестное слагаемое, уменьшаемое, множитель и т.п., логично познакомиться с уравнениями и других видов. Следующими по очереди идут линейные уравнения, целенаправленное изучение которых начинается на уроках алгебры в 7 классе. Понятно, что сначала надо объяснить, что такое линейное уравнение, дать определение линейного уравнения, его коэффициентов, показать его общий вид. Дальше можно разбираться, сколько решений имеет линейное уравнение в зависимости от значений коэффициентов, и как находятся корни. Это позволит перейти к решению примеров, и тем самым закрепить изученную теорию. В этой статье мы это сделаем: детально остановимся на всех теоретических и практических моментах, касающихся линейных уравнений и их решения. Сразу скажем, что здесь мы будем рассматривать только линейные уравнения с одной переменной, а уже в отдельной статье будем изучать принципы решения линейных уравнений с двумя переменными.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ПАСКАЛЬ Дан одномерный массив A[10]. Элементы массива – это случайные числа большие 0. Написать программу, которая будет находить произведение элементов массива, лежащих в интервале [20, 70].
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Староческуль-Станиславовна
sorokinae
Larisa-Andrei
Yurevich1344
orbbsvsupply
lele52
mantseva
amayonova
rykovatv6
Виталий_Ильназ574
a96849926288
Lyudmila-Popova
Ильдар-Кугай
demon8608
luxoutlet