Шавкат кызы
?>

Составьте программу сложения 3-х чисел, значения вводятся с клавиатуры. Информатика, программа паскаль​

Информатика

Ответы

Aleksandr-Andrei

var

a: integer;

b: integer;

c: integer;

begin

 readln(a,b,c);

 writeln (a+b+c)

end.

Объяснение:

kreon1

const

 AOper: array [0..3] of string = ('+', '-', '*', '/');

var

 a, b, Oper: Integer;

 r: Real;

begin

 Randomize;    // инициализация датчика случайных чисел

 a := Random (1001);

 b := Random (1001);

 Oper := Random (4);

 case Oper of

 0: r := a + b;

 1: r := a - b;

 2: r := a * b;

 3:if b <> 0 then begin

     r := a / b;

   end else begin

     WriteLn ('Произошла ошибка при делении на ноль');

     Exit;

   end

 else r := -1;

 end;

 WriteLn (a);

 WriteLn (b);

 WriteLn (Aoper [Oper]);

 if (r >= 0) and (r - Trunc (r) = 0) then begin   // если в результате получилось положительное целое число

   WriteLn ('yes');

   WriteLn (r :6 :0);

 end else

   WriteLn (' no');

 ReadLn;

end.

Объяснение:

r - Trunc (r) // это выделение дробной части числа

kirycha-2000719

1. Число не меньше 50 и четное: 50

2. Опечатка, вероятно. Либо наибольшее X - тогда 99, либо наименьшее натуральное x, и тогда это будет 1, либо НЕ меньше 100, тогда 101

3. Немного запутано, но по идее: число должно быть четным и меньше 10. Максимальное такое число: 8

4. X больше либо равен 7, или x меньше 6. Единственное число, которое НЕ подходит под эту формулу: 6

10. Обычное уравнение вида (4+3)^n+9 = 58 При том что n только натурален. Очевидно, что n = 2

17. Надо просмотреть каждую пару чисел и поставить плюсик, если первое больше 15 или второе больше 9. Я загнул пять пальцев, лучше меня перепроверить

25. У эсминца всего 2500 из которых 500 принадлежат также и фрегату. А всего-всего их 4500. Значит ТОЛЬКО эсминцу принадлежат 2000, ТОЛЬКО фрегату тоже 2000, а фрегату всего 2000+500 = 2500. Я понимаю, что ничего из этой писанины понять невозможно, так что прилагаю картиночку, написанную замороженной куриной лапой.

45. Столько писанины, а проще взять листочек в клеточку и самому побыть роботом, исполняя команды. Если у меня все верно, то за один цикл получается общее смещение на 1 вверх и 1 вправо. Значит за 5 циклов будет смещение (5,5) и чтоб переместиться в начало надо дать команду (-5,-5)

53. Третья строчка аналогична: a = 2*4 + 7*3. Любой второклассник скажет, что это 29. Четвертая строчка аналогична: b = 30-29 = 1. Таким образом, у нас a = 29, b = 1. А просят найти именно b. В ответ пишем 1


Объясните как это считать все к а к э т о де ла т ь. заранее целую в пупок. вот прям до вечера нужно

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу сложения 3-х чисел, значения вводятся с клавиатуры. Информатика, программа паскаль​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ohussyev
Vasilevna_Shabanova1502
sashab82
карпова581
olimov9
Suralevartem
ivan-chay19
Sokolova-Shcherbakov
Yurevich
astahova
Shipoopi8
alisabutusova
argent
aidapiltoyan43
nadejdashin508