katrinasvr
?>

1) Составить программу, возводящую отрицательное число в квадрат и вычисляющую квадратный корень из положительного числа. 2) Написать программу, проверяющую, принадлежит ли число, введенное с клавиатуры интервалу [5, 12. 3) Составить программу для решения квадратного уравнения.Pascal ABC

Информатика

Ответы

vik-2202
Var InFile, OutFile: text; // Вводной и выводной файлы
Var a,b,c, D, Result : Integer;
Assign(InFile, "C:\kvur.txt");
Assign(OutFile, "C:\korni.txt")
Reset(InFile)
Read(InFile,a)
Read(InFile,b)
Read(InFile, c)
D = sqr(b) + 4*a*c
if D = 0 then
Write("Уравнение не имеет корней")
Else
  Append(OutFile)
  Result:=(-b + sqrt(D)) / 2 * a
  Write(OutFile,Result)
  Write("Корень уравнения")
  WriteLn(Result)
  if (D>0) then
    Result:=(-b - sqrt(D)) / 2 * a
    Write(OutFile, Result)
    Write("Второй корень уравнения")
    Write(Result)
  End;
End.
juliaipatova1739
Здесь нужно проанализировать, какое слово следует написать в зависимости от введенного числа.
Если число оканчивается на 0, 5, 6, 7, 8, 9, то нужно написать "лет".
Если число оканчивается на 1, то нужно написать "год".
Если число оканчивается на 2, 3, 4, то нужно написать "года".
НО! Исключение составляют числа от 11, до 19, здесь всегда нужно писать "лет". Поэтому в программе проверяются и само число n и последний разряд этого числа x.

Программа:

program z;
var n,x:integer;
begin
readln(n);    {вводим число}
x:=n mod 10;    {вычислим последний разряд числа}
if (x=0) or ((n>10) and (n<=19)) or (x>=5) then writeln(n,' лет')
else
if x=1 then writeln(n,' год')
else
if (x>1)and(x<5) then writeln(n,' года');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Составить программу, возводящую отрицательное число в квадрат и вычисляющую квадратный корень из положительного числа. 2) Написать программу, проверяющую, принадлежит ли число, введенное с клавиатуры интервалу [5, 12. 3) Составить программу для решения квадратного уравнения.Pascal ABC
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pelagia-kola2658
AlekseiMardanova
jim2k
Irina1435
Оксана170
Исаченко Тераски1181
Вячеславович-Дмитрий1694
jeep75
egoryandiana3727283
yugraspets
ag-modul
maxchemaxim14
npprang21
Grishanin
toxicfish