zaseche99
?>

Составьте программу для решения следующей задачи: - ввести с клавиатуры три целых числа: х, y, z; - вычислить сумму всех чисел S = x + y + z; - вычислить сумму квадратов чисел Q = x2 + y2 + z2; (квадрат числа а – это произведение а*а) - вычислить сумму парных произведений R = x*y + x*z + y*z; - вывести полученные значения S, Q, R на экран

Информатика

Ответы

kuhonka2021
Правильный ответ: 7
Ты из пункта А в пункт B едешь 2км.
Из B в пункт E 5км.

То есть куда тебе нужно из серой клетки попасть в другую серую. Например из А в пункт B, ты уже проехал 2км. Далее смотришь по горизонтали куда можно поехать. Ты видишь 3км (в столбике С) и 5км (в столбике E). Например выбираешь С и спускаешь на серую клетку. Далее от неё смотришь 6 (столбик D) и 10 (столбик E). Дальше так же выбираешь и спускаешься, но это я на пример показал длинный путь. Самый кратчайший я написал под правильным ответом.
Надеюсь понятно объяснил, если что пиши в комментариях или в сообщения.
Veronika1270
Class MiddleTemperature{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); double tSum = 0;
  for(int day = 0; day<7; day++){
   switch(day){
 case 0: System.out.print("Понедельник>>"); break;
 case 1: System.out.print("Вторник>>"); break;
 case 2: System.out.print("Среда>>"); break;
 case 3: System.out.print("Четверг>>"); break;
 case 4: System.out.print("Пятница>>"); break;
 case 5: System.out.print("Суббота>>"); break;
 case 6: System.out.print("Воскресенье>>"); break;
   }
   tSum+=in.nextInt();
  } tSum/=7;
  System.out.print("Средняя температура за неделю: "+(int)tSum/1+"."+(int)(tSum%1.0/0.1)+(int)((tSum-(int)(tSum/0.1)/10D)/0.01));
 }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для решения следующей задачи: - ввести с клавиатуры три целых числа: х, y, z; - вычислить сумму всех чисел S = x + y + z; - вычислить сумму квадратов чисел Q = x2 + y2 + z2; (квадрат числа а – это произведение а*а) - вычислить сумму парных произведений R = x*y + x*z + y*z; - вывести полученные значения S, Q, R на экран
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lebedevevgen
juliaipatova1739
zakaz
verkop9
anovikovsr
Larisa-0888716
office
Никита_Тузов
Rik200081490
Zeitlinama7067
a580028r
Sergei Gaishun
evsyukov1997
kireevatatiana
galinaobraz