Шавкат кызы
?>

Переменные k и m описаны в программе как целочисленные. Определите значение m переменной после выполнения следующего фрагмента программы: Begin Dat[1] := 12; Dat[2] := 18; Dat[3] := 16; Dat[4] := 15; Dat[5] := 12; Dat[6] := 12; Dat[7] := 10; Dat[8] := 13; m := 0; for k := 1 to 8 do if Dat[k] > m then begin m := Dat[k]; end; writeln(m);

Информатика

Ответы

inainainainaina0073

ответ: 1 - C, 2 - B, 3 - B, 4 - B, 5 - B, 6 - C, 7 - B, 8 - B, 9 - C, 10 - D, 11 - A, 12 - B, 13 - B, 14 - B, 15 - D, 16 - C, 17 - B, 18 - D, 19 - C, 20 - B, 21 - D, 22 - B, 23 - B, 24 - C

Объяснение:

1. Предмет информатики — это накопления, хранения, обработки, передачи информации;

2. Тройками из нулей и единиц можно закодировать 8 различных символов.

3. Капитан спрашивает матроса: «Работает ли маяк?» Матрос отвечает: «То загорается, то погаснет!» Чем является маяк в этой ситуации? -  источником информации.

4. В каком веке появились первые устройства выполнять арифметические действия? -  В XVII в.

5. Механическое устройство, позволяющее складывать числа, изобрел Б. Паскаль.

6. Для какой системы счисления были при первые семикосточковые счеты? - для десятичной;

7. Какое устройство в России получило название «железный Феликс»? - механический арифмометр;

8. В какие годы XX столетия появилась первая электронно-счетная машина? - в 40-е;

9. В каком поколении машин ввод данных можно осуществлять с речи? -  4-м;

10. Архитектура компьютера — это описание устройства и принципов работы компьютера, достаточное для понимания пользователя.

11. Что такое микропроцессор? - Интегральная микросхема, которая выполняет поступающие на ее вход команды (например, вычисление) и управляет работой машины;

12. Подключение отдельных периферийных устройств компьютера к магистрали на физическом уровне возможно с контроллера;

13. Внешняя память необходима для  для долговременного хранения информации после выключения компьютера;

14. Для построения с компьютера сложных чертежей в системах автоматизированного проектирования используют графический планшет (дигитайзер);

15. К устройствам накопления информации относится ВЗУ.

16. Что из перечисленного не относится к программным средствам? - процессор;

17. Файлом называется поименованная область на диске или другом машинном носителе;

18. В каком файле может храниться рисунок? -  CREML.BMP.

19. Могут ли два каталога 2-го уровня иметь одинаковые имена? - да, если они принадлежат разным каталогам 1-го уровня;

20. Необходимым компонентом операционной системы является командный процессор;

21. Что такое система счисления? - это знаковая система, в которой числа записываются по определенным правилам, с знаков некоторого алфавита, называемых цифрами.

22. Какие системы счисления не используются специалистами для общения с ЭВМ? - троичная;

23. Что называется основанием системы счисления?» - отношение значений единиц соседних разрядов;

24. Все системы счисления делятся на две группы: позиционные и непозиционные;

Кириллов57
#include <iostream>
using namespace std;

int main() {
int a[50][2];
int n;
int k1=0;
int k2=0;
int k3=0;
int k4=0;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> a[i][0] >> a[i][1];
}
for (int i = 0; i < n; i++) {
if (a[i][1]>0)
  if (a[i][0]>0) k1++; else k2++;
 else if (a[i][0]>0) k4++; else k3++;
}
if ((k2>=3)or(k2==2)and(k1>3)or(k3>5)or(k4>9))
 cout << "Clock is broken" << "\n";
 else cout << k2 << k1 << ":" << k3 << k4 << "\n";
return 0;
}

Пример:
10
-1 1
1 1
1 2
-1 -1
-1 -2
-1 -3
1 -1
1 -2
1 -3
1 -4
12:34

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Переменные k и m описаны в программе как целочисленные. Определите значение m переменной после выполнения следующего фрагмента программы: Begin Dat[1] := 12; Dat[2] := 18; Dat[3] := 16; Dat[4] := 15; Dat[5] := 12; Dat[6] := 12; Dat[7] := 10; Dat[8] := 13; m := 0; for k := 1 to 8 do if Dat[k] > m then begin m := Dat[k]; end; writeln(m);
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natalia-shelkovich
Telenkovav
Татьяна902
kabinet17
alexsan-0837
sakh2010kprf7
nikdenly
vanvangog199826
baulinanatalia7201
kotikdmytriy11
vuyakovleva
Сергеевич1396
aluka
ludakamasana
myudanova631
▲