akakne86
?>

ОЧЕНЬ Задание 1. ( ) Написать программу на Паскале и построить блок-схему алгоритма для решения следующей задачи: Вычислить площадь прямоугольного треугольника по известным катетам. Длины катетов задать с оператора ввода самостоятельно. На проверку нужно прислать скриншоты с кодом и результатом работы программы, а также построенную блок-схему алгоритма. Задание 2. ( ) Дан четырехугольник АВСD. По длинам четырех отрезков (АВ, ВС, СD, DА), введенных пользователем с оператора ввода, определить, возможно ли в данный четырехугольник, составленный из этих отрезков, вписать окружность. Если действие возможно, вывести сообщение «Окружность вписать возможно», в противном случае – вывести сообщение об ошибке. Задание нужно выполнить на Паскале. На проверку нужно прислать скриншоты с кодом и результатом работы программы. Задание 3. ( ) Написать код на Паскале для решения задачи. Дан массив из 12 целых чисел. В заданном массиве найти максимальный четный элемент. Вывести на экран его значение и позицию в массиве. На проверку нужно прислать скриншоты с кодом и результатом работы программы.

Информатика

Ответы

Drugov_Vladimirovna

РЕЖИМЫ ДАТЧИКА СВЕТА: режим "Цвет". Датчик цвета умеет определять семь различных цветов: черный, синий, зеленый, желтый, красный, белый и коричневый цвета. Также если цвет определяется некорректно если предмет назодится далеко от датчика. Датчик определяет отсутствие цвета и приходит в состояние «без цвета».

Режим "Яркость отраженного света". РЕЖИМ ЯРКОСТЬ ОТРАЖЕННОГО СВЕТА: В режиме «яркость отраженного света» датчик цвета определяет яркость света, отраженного света светодиода датчика излучающего красный свет . Датчик использует шкалу от 0 (очень темный) до 100 (очень светлый) . Это означает, что ваш робот может быть запрограммирован таким образом, чтобы он двигался по белой поверхности до тех пор, пока не будет обнаружена черная линия, или чтобы он интерпретировал идентификационную карточку цветовым кодом.

РЕЖИМ ЯРКОСТЬ ВНЕШНЕГО ОСВЕЩЕНИЯ: В режиме«яркость внешнего освещения» датчик цвета определяет силу света, входящего в окошко из окружающей среды, например солнечного света или луча фонарика. Датчик использует шкалу от О (очень темный) до 100 (очень светлый) . Это означает, что ваш робот может быть запрограммирован таким образом, чтобы он подавал сигнал утром, когда восходит солнце, или чтобы он прекрашщал действие, если свет гаснет .

РЕЖИМ ЦВЕТОВ: Частота выборки датчика цвета составляет 1 кГц. Для наибольшей точности при выборе режима «Цвет» или «Яркость отраженного света» датчик следует расположить под прямым углом на расстоянии 10-15 мм к исследуемой поверхности, но не касаясь ее.

Kosov-Aleksandr379

Код на C++:

#include <iostream>

#include <ctime>

#include <cmath>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   srand(time(NULL));

   short res = 0;

   for(int i = 0; i < 3; i++)

   {

       res += (rand() % 6) + 1;

   }

   cout << pow(res, 2) << endl;

   

   return 0;

};

Объяснение:

В переменную res мы прибавляем случайное число от 1 до 6 (случайное значение вычисляется при функции rand()). Потом мы число возводим в квадрат и выводим его

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ОЧЕНЬ Задание 1. ( ) Написать программу на Паскале и построить блок-схему алгоритма для решения следующей задачи: Вычислить площадь прямоугольного треугольника по известным катетам. Длины катетов задать с оператора ввода самостоятельно. На проверку нужно прислать скриншоты с кодом и результатом работы программы, а также построенную блок-схему алгоритма. Задание 2. ( ) Дан четырехугольник АВСD. По длинам четырех отрезков (АВ, ВС, СD, DА), введенных пользователем с оператора ввода, определить, возможно ли в данный четырехугольник, составленный из этих отрезков, вписать окружность. Если действие возможно, вывести сообщение «Окружность вписать возможно», в противном случае – вывести сообщение об ошибке. Задание нужно выполнить на Паскале. На проверку нужно прислать скриншоты с кодом и результатом работы программы. Задание 3. ( ) Написать код на Паскале для решения задачи. Дан массив из 12 целых чисел. В заданном массиве найти максимальный четный элемент. Вывести на экран его значение и позицию в массиве. На проверку нужно прислать скриншоты с кодом и результатом работы программы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ietishkin
Suralevartem
vainshakov
rikki07834591
rastockin8410
Fateevsa9
sandovo590
edvlwork15
andrey4work918
Bi-1704
Николаевич1033
andreokiseleo69421
zverevahelen
mmi15
sahabiev1987