Векторная графика – вид компьютерной графики, в которой создание картинки происходит посредством математического описания.
Inkscape — графический редактор для создания на компьютере художественных и технических иллюстраций в формате векторной графики, полностью совместимый со стандартами XML, SVG и CSS .
• Инструмент"Карандаш" • Инструмент "Каллиграфическое перо" • Инструмент "Распылитель" • Инструмент "Ластик" • Инструмент "Градиентная заливка" • Инструмент "Пипетка" • Инструмент "Соединительные линии"
Объяснение:
ответ на фото надеюсь на 2 фото продолжение
В этой задаче удобно то, что если необходимо изменить значение размера массива, достаточно изменить соответствующую константу (SIZE1 или SIZE2). Так нам не придется менять эти значения ни в объявлении массивов, ни в параметрах при вызове функции.
Отдельно хочется сказать о передаче в функцию массива, как параметра. Мы говорили в уроке, что при вызове функции создаются точные копии переменных и все изменения происходят именно с этими копиями, а не с переменными. Так что при выходе из функции, переменные не изменят свое значение. Если всё же надо изменить значение переменных в функции – делается это с ссылок или указателей, которые мы рассмотрим в следующих уроках. С массивами дело обстоит иначе. Все что происходит с элементами массива в функции, сохраняется и после выхода из неё. Это происходит потому, что имя массива – это и есть указатель на его первый элемент.
Когда необходимо передать в функцию одномерный массив, при её определении надо указать пустые [ ] скобки после имени параметра, обозначающего массив. В нашей задаче – void fillAndShowArray(int arrayForFilling[], int size) . Если надо передать двумерный массив – первые квадратные скобки оставляют пустыми, а во вторые надо внести значение. Например void fillAndShowArray(int arrayForFilling[][3], int size)
Чтобы передать в функцию массив, при её вызове – достаточно использовать имя массива. Скобки и размер писать не надо (строки 14 – 15).
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу и начертить блок-схемы решения задач: Дан массив вещественных чисел, состоящий из 10 элементов. Найти максимальный элемент массива.
попробуй это. Тут еще с нахождением его номера
var a:array[1..100] of real;
i,imax,n:integer;
max:real;
begin
write('N= ');
readln(n);
for i:=1 to n do read(a[i]);
writeln('');
imax:=0;
max:=a[1];
for i:=1 to n do if a[i]>max then
begin max:=a[i];imax:=i;
end;
writeln('max = ',a[imax],' nomer = ',imax);
readln;
end.