annakorolkova79
?>

Разобрать методы сортировки массивов: пузырька, выбора, вставок, быстрая сортировка. Написать программу выполняющую шейкерную сортировку (при сортировке пузырьком самый легкий (наименьший) эл-т поднимается в начало за проход, при шейкерной - самый легкий поднимается, самый тяжелый опускается в конец.

Информатика

Ответы

NikolayGoncharov

import java.util.Scanner;

class Main {

   static int getNumb() {

       Scanner sxy = new Scanner(System.in);

       return sxy.nextInt();

   }

   public static void main(String [ ] args) {

       int x1 = getNumb();

       int y1 = getNumb();

       int x2 = getNumb();

       int y2 = getNumb();

       String can = "NO";

       if((x1 + 1 == x2) || (x1 - 1 == x2) && y1 == y2) {

           can = "YES";

       }

       else if((y1 + 1 == y2) || (y1 - 1 == y2) && x1 == x2) {

           can = "YES";

       }

       else if((x1 + 1 == x2 && y1 + 1 == y2) || (x1 + 1 == x2 && y1 - 1 == y2) || (x1 - 1 == x2 && y1 + 1 == y2) || (x1 - 1 == x2 && y1 - 1 == y2)) {

           can = "YES";

       }

       System.out.print(can);

   }

}

papushinrv4985

Это таблица истинности для логических функций. Галочка вверх означает логическое И, галочка вниз - логическое ИЛИ, уголок перед переменной - логическое НЕ. Это тема обширная, и так что если я представлю здесь решение это все равно вам не понять. Вам нужно почитать о логических функциях и таблицах истинности.

Вот как выглядит решение. Поставляем значения из таблицы истинности в варианты функций. Та функция, результат которой совпадает с результатом из таблицы, является ответом. В данном случае это номер 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Разобрать методы сортировки массивов: пузырька, выбора, вставок, быстрая сортировка. Написать программу выполняющую шейкерную сортировку (при сортировке пузырьком самый легкий (наименьший) эл-т поднимается в начало за проход, при шейкерной - самый легкий поднимается, самый тяжелый опускается в конец.
Ваше имя (никнейм)*
Email*
Комментарий*