Равиль_Евгеньевич1808
?>

написать программу на языке Паскаль или в PascalABC, нахождение кинетической энергии ( формула из физики) скорость 15, масса 12

Информатика

Ответы

esnails17

Объяснение:

uses GraphABC,Events,Utils;                 //необходимые библиотеки подключены

var pr,px,py,kx,ky,ku,pc,s: integer;          //переменные: положение ракетки, координаты мяча, коэффициенты отражения, положение ракетки компьютера

 

procedure KeyDown(Key: integer);           //процедура обработки нажтия клавиши

begin

 case Key of

VK_Up: if pr>10 then pr:=pr-10;           //если вверх, и если ракетка не достигла края экрана, сместить координаты ракетки на 10 вверх

VK_Down: if pr<490 then pr:=pr+10;        //то же, только вниз

 end;

end;

 

procedure Pm;                             //процедура определения координат мячика

begin

if px<10 then

  begin

  kx:=kx*(-1);                //если достиг стенки левой - поменять коэффициент смещения по х на противоположный

  s:=random(2);

  if s=1 then ky:=ky*(-1);

  end;

if (py<10) or (py>490) then ky:=ky*(-1);  //если достиг стенки верхней или нижней - поменять коэффициент смещения на противоположный

if px>590 then                            //если достиг правой (игрока) стенки, проверяем

  if (py>pr-20) and (py<pr+20) then kx:=kx*(-1) else  //если координаты мяча совпадают с координатами ракетки, меняем коэффициент смешения по х на противоположный

  begin                                 //иначе

  showmessage('Вы упустили мячик!');    //выводим сообщение

  inc(ku);                              //увеличиваем счетчик упущенных мячей

  px:=15;                               //возвращаем мяч в исходную позицию у противоположной стенки

  py:=250;

  end;

px:=px+kx;                               //смещаем координаты на коэффициенты смещения

py:=py+ky;

end;

 

begin

lockdrawing;                            //запрет прорисовки в окне (мигание убираем)

setwindowsize(600,500);                 //размер окна

kx:=5; ky:=1; px:=15; py:=250; pr:=250; //задаем координаты смещения и позицию мяча

repeat                                  //цикл с постусловием

 clearwindow;                          //очистить окно

 setbrushcolor(clgreen);               //цвет кисти зеленый

 rectangle(5,5,595,495);               //прямоугольник - поле

 Pm;                                   //процедура определения координат мяча

 setbrushcolor(clwhite);               //цвет кисти - белый

 circle(px,py,10);                     //мяч

 OnKeyDown:=KeyDown;                   //процедура нажатия клавиши

 pc:=py;                               //ракетка противника следует за мячом неотступно...

 setbrushcolor(clblack);               //цвет кисти - черный

 rectangle(592,pr-20,597,pr+20);       //ракетки

 rectangle(3,pc-20,8,pc+20);

 sleep(25);                             //задержка

 redraw;                               //перерисовка

until ku=5;                             //цикл повторяется до 5 пропущенных мячей

end.

Maksimova1320

Функция нахождения индекса макс. числа массива:

int max, maxl, counter;

max = array[0];

 for(int i = 0; i < size; i++){

  if (array[i] > max) {

       max = array[i];

       maxI = i;

      }

 }

Дальше проходимся по массиву от нулевого элемента и до макс.элемента и ищем чётные числа:

counter = 0;

for (int i=0; i<maxl; i++)

{

   if ( array[i]%2 != 0)

       counter++;

}

printf( "number of odd numbers is: %d", counter);

Должно заработать, только оформите как подобает, если нет - обращайтесь, починим )

orion-inginiring7807

Python 3.7.0

Лови, прикрепил фото с результатами, посмотри(т.е сразу выводит, после "следующий")


count = int(input("Количество событий: "))

queue = []      # очередь

for i in range(count):

   event = input()

   if "Кто последний?" in event:

       queue.append(event[19:len(event) - 1])

   if "Я только спросить!" in event:

       queue.insert(0, event[23:len(event) - 1])

   if "Следующий!" in event:

       if queue:

           print("Заходит " + queue.pop(0) + "!")

       else:

           print("В очереди никого нет.")


Окунёмся в суровый и беспощадный мир очереди на приём к врачу в поликлинике. напишем программу-медсе

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу на языке Паскаль или в PascalABC, нахождение кинетической энергии ( формула из физики) скорость 15, масса 12
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mbykovskiy
Liliya-buc
mishamedbrat
Gennadievna bessonov
notka19746
germanleon
betepah
nunabat457
Aleksei1463
Yevgenevna
byfetvostochniy
gladkihvv
annakuznetsova841
reception
Акимцева27